Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 7 years ago

Closed 7 years ago

#2839 closed patch (fixed)

Enable virtual keyboard for ComboBox

Reported by: devel@… Owned by: paulh
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: combo virtual keyboard
Cc: Ticket locked: no

Description

Patch to allow use of VirtualKeyboard? with ComboBoxes?. In it's current state this patch pops up the keyboard correctly, but segfaults when entering characters. I cannot work out the correct way to send the keypresses to the combobox.

Attachments (1)

combovirtualkeyboardpopup.diff (3.9 KB) - added by devel@… 7 years ago.
Enable virtual keyboard for editable combo

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by devel@…

Enable virtual keyboard for editable combo

comment:1 Changed 7 years ago by paulh

  • Owner changed from ijr to paulh
  • Status changed from new to assigned

The problem is that UIKeyboardType expects that either a QLineEdit or QTextEdit or a widget that inherits them is passed to it when SetEdit?() is called in VirtualKeyboard::switchLayout(). The way you have it at the moment you are passing a MythComboBox? which doesn't inherit any of the required edit widgets. It should be easy to fix though, you can get the QLineEdit an editable QComboBox is using by calling QComboBox::lineEdit(). I'll take a look at it.

comment:2 Changed 7 years ago by paulh

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [12347]) Enable the popup keyboard to work with editable comboboxes.
Patch from devel (at) mrwire (dot) co (dot) uk with a small fix by me
to get it to work properly.

I updated the MYTH_BINARY_VERSION to be on the safe side. Not sure its really
needed in this case though.

Closes #2839.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.