Opened 13 years ago

Closed 13 years ago

#2849 closed defect (duplicate)

Problem finding keyframes in some recordings

Reported by: doug@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have some ATSC (OTA, DVB drivers) recordings whose seektable was written incorrectly -- the entries point to packets in the file that are not even picture start, and there are a whole lot more entries than should exist.

'mythcommflag --rebuild' on one of these files picks up most (but not all) of the keyframes correctly, but the frame number is incorrect. Both of these problems cause trouble seeking.

Recordings from other stations, and some other recordings from the same station, are fine.

This is with 0.20-fixes, but I don't see that a whole lot has changed in dtvrecorder since that time.

I have debugged this problem as far as I am able for the time being. I've put a bunch of data at http://www.parkercat.org/doug/wgbh-weird/ (behind a cable modem, so please go easy):

  • wgbh-weird.ts -- first 200MB of an example bad recording
  • before-commflag.gnumeric -- recordedseek entries for this recording, imported to Gnumeric
  • after-commflag.gnumeric -- recordedseek entries after 'mythcommflag --rebuild'
  • wgbh-weird-gopdump.txt -- slightly-formatted dump of the GOP-containing TS packets, as reported by:
  • tsdump and tsdump.C -- my old program to do minimal parsing on MPEG2-TS files for debug (Linux binary & source)

Change History (1)

comment:1 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #799.

Note: See TracTickets for help on using tickets.