Opened 13 years ago

Closed 13 years ago

#2944 closed enhancement (fixed)

Adds program number tuning

Reported by: danielk Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This patch adds program number only tuning to digital recorders, with a special optimization for HDHomeRun tuners with the latest firmware.

Attachments (3)

2944-v4.patch (30.8 KB) - added by danielk 13 years ago.
logs.tar.gz (10.7 KB) - added by anonymous 13 years ago.
Mythbackend log + channel&dtv_multiplex dumps
2944-fix-v1.patch (646 bytes) - added by danielk 13 years ago.
Probable fix for DVB tuning

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by danielk

Attachment: 2944-v4.patch added

comment:1 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [12619]) Fixes #2944. Adds Program Number only tuning to digital recorders.

Normally we tune using the VCT, SDT or NIT since these are almost always unique accross transports. This change allows you to tune using just the PAT and PMT instead. By default this is disabled, because it is not as reliable. But you can enable it on a per input basis in the input connections editor of mythtv-setup.

I would recommend that this not be enabled when using DVB-S with a rotor, or with any DVB cards with known frequency tuning problems.

comment:2 Changed 13 years ago by tpv

Resolution: fixed
Status: closedreopened

Hi

This fix doesn't work fully. If I select Watch TV from main menu, I only get a blank screen and after a little while a notice screen "You should have gotten a channel lock by now...". If I then press OK and select another channel with up/down, the selected channel works ok. I live in Finland and use DVB-C tuners.

comment:3 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

tpv, this isn't a fix for anything, it's an enhancement.

Was tuning working before, are you having problems with this feature enabled or when it is disabled? As noted in the commit it will not work with some DVB drivers.

Please reply in MythTV Developer mailing list.

Changed 13 years ago by anonymous

Attachment: logs.tar.gz added

Mythbackend log + channel&dtv_multiplex dumps

comment:4 Changed 13 years ago by tpv

Resolution: fixed
Status: closedreopened

Requested mythbackend log + channel&dtv_multiplex dumps added

Changed 13 years ago by danielk

Attachment: 2944-fix-v1.patch added

Probable fix for DVB tuning

comment:5 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [12626]) Fixes #2944. Fixes a problem with DVB tuning caused by [12619].

The DVBChannel class has some smarts to skip tuning when it isn't needed, but unfortunately [12619] cleared out some of the tuning info before the redundant tune code was run. This meant tuning failed whenever these smarts were triggered.

Note: See TracTickets for help on using tickets.