Opened 13 years ago

Closed 12 years ago

#3181 closed defect (invalid)

Mythfrontend hangs after playing video with mplayer

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: stuartm Ticket locked: no

Description

Ever since I started using mythwelcome, I have problems with my frontend hanging after using mplayer to play a movie. It is not happening immediately, if I start mplayer and quit it within 60 seconds or so, all is well, but after a few minutes, I can reproduce the hang nearly 100% of the time. Attached is gdb output and a few other things I thought relevant. If more is needed, I'll be happy to provide it.

Attachments (1)

dbg (13.0 KB) - added by leoweppelman@… 13 years ago.
Output from gdb & ps

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by leoweppelman@…

Attachment: dbg added

Output from gdb & ps

comment:1 Changed 13 years ago by stuartm

Cc: stuartm added
Version: 0.20head

comment:2 Changed 12 years ago by leoweppelman@…

I am no longer able to reproduce this. I think this bug is caused by some kind of a locking error. The things changed after the last time this happened are:

  • I upgraded myth to the svn revision: 14432. I did this because of the latest dvd speed updates
  • I removed my old code that tried to keep the speed down with help of an external program. It was fired once a second or so from the media monitor loop.

I think reducing the number of forks somehow fixed the problems with the wait.

comment:3 Changed 12 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.