Opened 13 years ago

Closed 13 years ago

#3315 closed defect (invalid)

Rewinding/fast forwarding above 3X doesn't work with libmpeg2, but does with Standard/ffmpeg

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20-fixes
Severity: medium Keywords: ffmpeg libmpeg2 Standard rewind fast forward fastforward
Cc: Ticket locked: no

Description

I use ATrpms 0.20-fixes r13228 (and ATrpms libmpeg2_0-0.4.1-3 and ATrpms ffmpeg 0.4.9-19_r7407, all on Fedora Core 6 64-bit on EM64T), but this is a problem I've had since my first days of MythTV more than a year ago.

Rewinding or fast forwarding recordings--whether HD or not--during playback has never worked right for me. 3X works fine as far as I can tell, but any faster speed (5X, 10X, etc.) means that the video will stop "moving" after four or five seconds. Pushing Play always resumes playback normally, so it's not quite a duplicate of #745 or #2434 (which involve different hardware, anyway).

I never bothered to report the issue because time skips are a very adequate substitute. However, very recently I've discovered that this is only an issue with the libmpeg2 decoder; using the Standard/ffmpeg decoder does permit rewinds and fast forwards to work properly. (I don't know whether in the past this issue existed with both decoders, but that's the way things stand right now.)

Change History (1)

comment:1 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

Not a MythTV bug. libmpeg2 just abandones decoding when it doesn't have enough time, this is why we force ffmpeg for preview generation.

Note: See TracTickets for help on using tickets.