Opened 13 years ago

Closed 13 years ago

#3467 closed patch (duplicate)

Lack of XRandR extension causes a segfault on startup

Reported by: Allan Stirling Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Currently, if the display used by Myth does not support the XRandR extension, Myth calls GetScreenConfig?. This causes a segfault. This patch first checks for the availability of the extension before attempting to use any XRandR functions.

Attachments (1)

noxrandr.1.patch (1.5 KB) - added by Dibblah 13 years ago.

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by Dibblah

Attachment: noxrandr.1.patch added

comment:1 Changed 13 years ago by Jarod Wilson

Resolution: duplicate
Status: newclosed

Per Allan himself, this is a duplicate of #3401.

Note: See TracTickets for help on using tickets.