Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#35 closed patch (fixed)

mythvideo gallery crashes when Menu button is pressed

Reported by: Robert Tsai <rtsai1111> Owned by: Isaac Richards
Priority: minor Milestone: 0.19
Component: mythvideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In the MythVideo? gallery (the view with the grid of video cover art), pressing "menu" crashes mythfrontend.

I'm not exactly sure what the intended behavior is, but this patch makes the "menu" button bring up the usual "switch to browse view", "switch to list view", popup that appears when pressing "menu" in the browse or list views.

Attachments (2)

mythvideo.focusButton.diff (761 bytes) - added by Robert Tsai <rtsai1111> 14 years ago.
mythvideo.focusButton.2.diff (1.7 KB) - added by Robert Tsai <rtsai1111> 14 years ago.
v2

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by Robert Tsai <rtsai1111>

In the MythVideo? gallery (the view with the grid of video cover art), pressing "menu" crashes mythfrontend.

I'm not exactly sure what the intended UI behavior is, but this patch makes the "menu" button bring up the usual "switch to browse view", "switch to list view", popup that appears when pressing "menu" in the browse or list views.

Changed 14 years ago by Robert Tsai <rtsai1111>

Attachment: mythvideo.focusButton.diff added

comment:2 Changed 14 years ago by Robert Tsai <rtsai1111>

Version: head

Changed 14 years ago by Robert Tsai <rtsai1111>

v2

comment:3 Changed 14 years ago by Robert Tsai <rtsai1111>

This crash only happens when "VideoGalleryNoDB" == 1 (e.g., "browse files" mode).

comment:4 Changed 14 years ago by jdonavan

Resolution: fixed
Status: newclosed

(In [6760]) Fix a segfault cause by not having a focusButton when in file mode in the video gallery when the user pressed MENU.

Thise closes #35 but not with the patches that were attached to the report

Note: See TracTickets for help on using tickets.