Opened 12 years ago

Closed 12 years ago

#3675 closed defect (duplicate)

Usage of mcpu is incorrect

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As per the GCC documentation, the usage of mcpu is incorrect. mcpu is a deprecated option that has been replaced by mtune.

http://gcc.gnu.org/onlinedocs/gcc/i386-and-x86_002d64-Options.html

Since the configure script uses mtune and mcpu on the same line, that's totally wrong. Attached is a patch that makes mcpu into march, which would be much more proper.

mcpu is going away in future GCC versions.

Attachments (1)

mythtv-mcpu-is-wrong.patch (2.8 KB) - added by cardoe@… 12 years ago.
mythtv-mcpu-is-wrong.patch

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by cardoe@…

Attachment: mythtv-mcpu-is-wrong.patch added

mythtv-mcpu-is-wrong.patch

comment:1 Changed 12 years ago by anonymous

The patch is a simple sed. It should be cleaned up further by removing mtune where march and mtune are equal since march sets mtune to the march value if mtune isn't set.

comment:2 Changed 12 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed

Dupe of #3231.

Note: See TracTickets for help on using tickets.