Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#372 closed defect (worksforme)

Picture pixelation when skipping forward or backwards during playback

Reported by: perveilerj@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I recently upgraded from r7270 to r7306 and noticed that when I try to jump/skip forward or backwards I usually get pixelation or noise on the screen for about a second. On occasion everything displays correctly, but not usually. After about a second things recover and look normally. This happens for both HD content (recorded from hd3k card w/DVB drivers) and SD content (recorded on pvr500).

This didn't occur in r7270 but I don't know when it started happening between r7270 and r7306.

I don't know what verbosity to use but I'd be happy to collect logs...

Change History (13)

comment:1 Changed 14 years ago by tom@…

I am also seeing this in 7289. Not sure exactly when it started, but I really noticed it last night. I too can send logs if needed.

comment:2 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [7308]) Should fix seeking funkiness due to [7284].

Fixes #372.

comment:3 Changed 14 years ago by tom@…

Resolution: fixed
Status: closedreopened

Hate to do this, but it's still happening in 7308. It's better than it was but it's still doing it. I also noticed a strange problem in that the first time I try to skip forward, it actually skips backwards by the 'smart forward' amount (in my case 5 seconds), if I skip forward again it then skips forward by the regular skip of 30 seconds. This is with regular SD TV recorded with a PVR-250.

comment:4 Changed 14 years ago by jonese@…

A similar problem is also the inability to rewind while watching LiveTV (even with 7308 applied).

comment:5 Changed 14 years ago by tom@…

Live TV seems to go nuts on me occasionally. When I went to see if I had the same problem as jonese@…, it was unwatchable. The OSD kept flashing on the screen, and it would pause and unpause by itself. I closed the frontend and restarted it from a console to see if I could get some idea of what was happening, and now it's fine. Weird.

Another problem I've noticed, and I'm not sure if it's related or not, is that with commercial auto-skip on, it's premature, in that it seems to skip about 5 seconds before it should (cutting off part of the show) and it ends early (in that you see the last 5 seconds of the last commercial in the break).

If there are any specific logs you'd like to see, let me know and I'll try and produce them.

Tom

comment:6 Changed 14 years ago by anonymous

Just compiled 7308, with ivtv 0.3.8.

Forward frame stepping is working, backwards frame stepping gives pixellation. This was viewing a recording made with the slightly earlier version.

Viewing a recording made with 7308 works fine here for stepping forwards and back.

comment:7 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed

Recordings made while it was broken need rescanned by mythcommflag.

comment:8 Changed 14 years ago by anonymous

Resolution: fixed
Status: closedreopened

Your resolution did not address LiveTV.

comment:9 Changed 14 years ago by Isaac Richards

Resolution: worksforme
Status: reopenedclosed

Fixed it for me.

comment:10 Changed 14 years ago by anonymous

A later patch [probably 7316] appears to have cleared up some/most/all of the problem (I can atleast rewind LiveTV now).

comment:11 Changed 14 years ago by anonymous

This is still occuring for me with 7316. mythcomflag --rebuild on the specific shows did not help. Live TV works fine. It is only on recordings that I am seeing this. The recordings are in mpg format if that matters any.

comment:12 Changed 14 years ago by perveilerj@…

I'm also still seeing this problem (with r7308). I mythcommflagged everything again after updating to r7308, and the problem is MUCH, MUCH better, but it still occurs occasionally (I'd call it "rare" now).

Is it possible that "worksforme" is still broken, just happening a lot less frequently? It's certainly tolerable now and I'm not losing any sleep over it... I just wanted to throw out there that it still isn't perfect.

comment:13 Changed 14 years ago by anonymous

Recordings made after [7284] but prior to [7308] still pixilize on seeking, even after upgrading to current and a mythcomflag --rebuild. I do not think this can be fixed as it seems to be the recorded file is the source of the problem now.

Note: See TracTickets for help on using tickets.