Opened 13 years ago

Closed 13 years ago

#3744 closed defect (fixed)

Fix broken image references in music-ui.xml

Reported by: Roo <roo.watt@…> Owned by: Justin Hornsby
Priority: minor Milestone: unknown
Component: theme Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I suspect the recent cleanup broke this, but not sure as I don't usually use any of these themes.

This problem breaks the editmetadata screens, maybe others as well.

The affected image references are:

mm_checked.png
mm_unchecked.png
mm_checked_high.png
mm_unchecked_high.png

mm_blankbutton_on.png
mm_blankbutton_off.png
mm_blankbutton_pushed.png

mm_leftright_on.png
mm_leftright_off.png
mm_leftright_pushed.png

Patches attached fix the music-ui.xml files, although maybe it was intended that the mm_* files were created instead. ie svn copy blankbutton_on.png mm_blankbutton_on.png, although default-wide/music-ui.xml refers to blankbutton_on.png etc.

Roo

Attachments (2)

mythtv_music-ui.xml.diff (9.1 KB) - added by Roo <roo.watt@…> 13 years ago.
myththemes_music-ui.xml.diff (9.1 KB) - added by Roo <roo.watt@…> 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by Roo <roo.watt@…>

Attachment: mythtv_music-ui.xml.diff added

Changed 13 years ago by Roo <roo.watt@…>

comment:1 Changed 13 years ago by Roo <roo.watt@…>

see changesets [12897], [12893] and [12903]

comment:2 Changed 13 years ago by Justin Hornsby

Resolution: fixed
Status: newclosed

Should now be fixed by [13983] and [13974]. I made new images for blue & G.A.N.T., as close to the original theme style as I could. Sorry your patches aren't used - IMHO the new images will be more in keeping with the rest of each theme instead :)

comment:3 Changed 13 years ago by Roo <roo.watt@…>

Resolution: fixed
Status: closedreopened

I have just done some testing on a clean install of trunk r14012. There are still a couple of probs, below is a summary:

Missing checkbox, button images (caused by removed mm_* images):

  • Titivillus
  • Minimalist-wide

Metadata editor screen ("i" from playlist) missing "Track Info" & "Album Art" buttons

  • Titvillus
  • Blue
  • G.A.N.T.
  • Minimalist-wide

The "myththemes_music-ui.xml.diff" will address the checkbox images etc in Titivillus and Minimalist-wide themes.

I will provide a patch for the buttons unless someone beats me to it :)

* Thinking a bit more about this, I suspect the problem has gone unnoticed as people would still have the mm_* images installed from prior to [12897], when they were removed. I was testing from a clean install, with a clean /usr/local/

Not a big deal in the grand scheme of things :)

comment:4 Changed 13 years ago by Justin Hornsby

Resolution: fixed
Status: reopenedclosed

Closing this. Will fix the 'missing' theme elements very soon - they should by rights have been on a separate ticket in any case.

Note: See TracTickets for help on using tickets.