Opened 12 years ago

Closed 12 years ago

#3745 closed patch (fixed)

Fix bug in mythgallery File Copy

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythgallery Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Column 'keywords' does not exist in gallerymetadata table resulting in a copied file always being deleted. Fixed in attached patch.

Attachments (1)

mythgallery_cp_fix (698 bytes) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by anonymous

Attachment: mythgallery_cp_fix added

comment:1 Changed 12 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Version: unknownhead

comment:2 Changed 12 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [14105]) The INSERT query in GalleryUtil::Copy referenced a non-existant column in the gallerymetadata table causing it to always fail. This apparently allows the copy function to work as intended, but I don't use mythgallery so I cannot confirm.

Fixes #3745

Note: See TracTickets for help on using tickets.