Opened 12 years ago

Closed 12 years ago

#3940 closed defect (duplicate)

Segfault adding record override after viewing program details

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Sequence:

  • go to "Upcoming Recordings" page
  • view program details for an upcoming recording, then go back (hit "u", "ESC")
  • view recording dialog (hit "space")
  • add override (select "Don't Record" or "Add Override")
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209124592 (LWP 23163)]
0x004e1532 in ScheduledRecording::makeOverride (this=0x89c2de0) at scheduledrecording.cpp:941
941	    parentid->setValue(m_pginfo->recordid);

Backtrace will follow. I believe the problem is that ProgramInfo::showDetails initializes "record" using loadByID, which does not set "record->m_pginfo". Then, when ApplyRecordStateChange calls GetProgramRecordingStatus, "record" is left unchanged.

This is with r14355 but the affected files seem to be unchanged in HEAD.

The attached patch seems to fix it.

Attachments (2)

mf-14355-segfault.log (9.4 KB) - added by gtgj@… 12 years ago.
backtrace of segfault with program details -> add override
mf-14355-segfault.patch (424 bytes) - added by gtgj@… 12 years ago.
patch for segfault

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by gtgj@…

Attachment: mf-14355-segfault.log added

backtrace of segfault with program details -> add override

Changed 12 years ago by gtgj@…

Attachment: mf-14355-segfault.patch added

patch for segfault

comment:1 Changed 12 years ago by gtgj@…

(Sorry, reporter field got reset to "anonymous". It should be me. Also, formatting is messed up. Here is the sequence for reproducing the segfault:)

Sequence:

  • go to "Upcoming Recordings" page
  • view program details for an upcoming recording, then go back (hit "u", "ESC")
  • view recording dialog (hit "space")
  • add override (select "Don't Record" or "Add Override")

comment:2 Changed 12 years ago by paulh

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #3321

Note: See TracTickets for help on using tickets.