Opened 12 years ago

Closed 11 years ago

#3953 closed defect (duplicate)

mythfrontend looking for wrong file during LiveTV SwitchToProgram AND Recording Playback

Reported by: anonymous Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version: 0.20-fixes
Severity: medium Keywords: RingBuf SwitchToProgram
Cc: mathias.smith@… Ticket locked: no

Description

This sounds an *AWFUL* lot like 2335, but I'm not quite sure:

I'm using a combined FE/BE with latest 0.20.2, but this also applies to 0.20.0. Ran smooth for several months on FC6. Then, I tried MythDora? 4. It worked well, but I would occasionally get a frontend "Error displaying video" error while watching LiveTV. Whenever this occurred it was always exactly on the half-hour or the hour. Then, I installed latest 0.20.2 on Ubuntu Feisty a couple days ago, and I'm having the same problems. Mythfrontend stderr looks like:

... 2007-09-09 07:30:06.327 RingBuf?(/var/lib/mythtv/recordings/1021_20070908070000.mpg): Invalid file (fd -1) when opening '/var/lib/mythtv/recordings/1021_20070908070000.mpg'. 2007-09-09 07:30:07.982 NVP, Error: SwitchToProgram?'s OpenFile? failed ...

Last night, I also noticed this happens with trying to playback a previously recorded show. When I went to play the show, I also got the same ringbuf error listed above. Interestingly enough, the show WAS recorded, but under a slightly different filename.

Mythfrontend was looking for: /var/lib/mythtv/recordings/1021_20070908070000.mpg

But, the show was dutifully recorded in its entirety in: /var/lib/mythtv/recordings/1021_20070908070430.mpg

I looked in the database, and indeed the entry for the recording had a different filename than that on the disk. Why would mythbackend log the filename in mysql with a different string than the filename that gets written to the disk?

I can send any listings or specs that would be helpful...

Change History (2)

comment:1 Changed 12 years ago by anonymous

I've got something like this too when I try to watch live tv.

2007-10-12 16:42:06.826 Preview Error: Previewer file '/opt/recordings/1097_20071012164205.mpg' is not valid. But the file is named 1097_20071012164206.mpg on the disk.

BE and FE is not on the same machine. This almost never happened when I was using rev 14498 from 0.20-fixes, but today I updated to rev 14666 on the same branch and hasn´t been able to see any live TV since that.

comment:2 Changed 11 years ago by danielk

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #2335.

The problem anonymous commented on after #2335 was fixed is a separate and trivial issue having to do with the previewer being run on placeholder files.

Note: See TracTickets for help on using tickets.