Opened 12 years ago

Closed 11 years ago

#4590 closed defect (invalid)

Pressing select/enter from guide on a channel will not switch channel

Reported by: anonymous Owned by: skamithi
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: eric.bosch@… Ticket locked: no

Description

Just upgraded from 15699 to 15759 and when browsing guide from live tv and pressing enter/select on a channel to switch to that channel, guide just exits back to original channel. I have the option selected in frontend to switch channels when select is pressed in the guide. This was not happening on 15699.

Also noticed guide data from schedulesdirect no longer getting to the guide for some reason too.

Change History (14)

comment:1 Changed 12 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Status: newassigned
Version: unknownhead

comment:2 Changed 12 years ago by danielk

I've confirmed that select does not work in head with "Setup"->"TV Settings"->"Program Guide"->"Use select to change the channel in the program guide" checked.

comment:3 Changed 12 years ago by anonymous

I can't seem to pinpoint where it got broken but it seems this happened somewhere between 15699 and 1575ish. Anyone has a clue?

comment:4 Changed 12 years ago by eric.bosch@…

Yes, same here. CC Me, Thanks

comment:5 Changed 12 years ago by Janne Grunau

Cc: eric.bosch@… added

comment:6 Changed 12 years ago by skamithi

Owner: changed from danielk to skamithi

Yes. i introduced the problem. sorry about that. I'll fix that today.

comment:7 Changed 12 years ago by skamithi

Resolution: fixed
Status: assignedclosed

(In [15826]) Closes #4590. Refs #4568. fix pressing select/enter from guide on a channel will not switch channel created by [15753].

comment:8 Changed 12 years ago by anonymous

Resolution: fixed
Status: closednew

This is still broken as of 15873. I believe it began around the time of the multirec merge.

comment:9 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

Works for me after [15826]. Are you sure you updated properly?

comment:10 Changed 12 years ago by anonymous

Resolution: fixed
Status: closednew

Yes. Everything is updated properly. The issues seems limited to channels that have the same callsign/name.

comment:11 Changed 12 years ago by eric.bosch@…

This has worked correctly for me since 15826, but I am still having one issue, not sure if it is related or not... If I am watching LiveTV and tuned to a station below channel Number < 100, the guide comes up with the very top channel selected in the guide, instead of the current channel being watched, but if I'm watching any channel at or above 100, the correct channel is selected when you enter the program guide.

comment:12 Changed 12 years ago by anonymous

After further testing, it only affects channels with the same callsign. If you are on a channel with the callsign FOX, you cannot select in the guide on a different channel with the callsign FOX. As long as the callsign is different than the currently tuned channel, the channel change will work.

comment:13 Changed 12 years ago by skamithi

Milestone: 0.21unknown

comment:14 Changed 11 years ago by Dibblah

Resolution: invalid
Status: newclosed

If channels have a duplicate callsign, they are assumed to have identical content.

Note: See TracTickets for help on using tickets.