Opened 12 years ago

Closed 12 years ago

#4664 closed defect (fixed)

mythshutdown verbose output missing

Reported by: Nigel Owned by: Nigel
Priority: minor Milestone: unknown
Component: mythshutdown Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Bill reported: I get "mythshutdown: Could not initialize myth context. Exiting." in my mythbackend log when the scheduler attempts begin the shutdown sequence.
This may be due to HOME not being set, but it appears vital VERBOSE output, explaining the problem, is missing. Suspect that the verbose mask is not being set early enough.

Change History (4)

comment:1 Changed 12 years ago by paulh

Resolution: wontfix
Status: newclosed

mythshutdown is silent by design that's because it's called very often by the BE and if it wasn't it would quickly fill the BE log with useless messages. You can of cause always override that by adding whatever verbose flags you want.

comment:2 Changed 12 years ago by Nigel

Resolution: wontfix
Status: closednew

That is the problem. mythshutdown -v all didn't add any extra output (esp. MythCOntext related output). The call to parse the verbose flags needs to be earlier,

comment:3 Changed 12 years ago by Nigel

Owner: changed from Isaac Richards to Nigel
Status: newassigned

comment:4 Changed 12 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [16033]) Initialise MythContext later, so we can get -v output from it. Closes #4664

Note: See TracTickets for help on using tickets.