Opened 12 years ago

Closed 12 years ago

#4921 closed defect (invalid)

When attempting to change channel MySQL crashes

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords: mysql
Cc: Ticket locked: no

Description

MythTV Version : 16495 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_backend using_dbox2 using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

errors at time of losing mysql:

2008-03-10 22:51:57.819 MSqlQuery: SELECT title, subtitle, description, category, starttime, endtime, callsign, icon, channum, seriesid, programid FROM program, channel WHERE program.chanid = channel.chanid AND channel.chanid = 2082 AND starttime <= '2008-03-10T22:51:57' ORDER BY starttime desc LIMIT 1 2008-03-10 22:51:57.819 DB Error (GetNextProgram? -- get program info): Query was: SELECT title, subtitle, description, category, starttime, endtime, callsign, icon, channum, seriesid, programid FROM program, channel WHERE program.chanid = channel.chanid AND channel.chanid = 2082 AND starttime <= '2008-03-10T22:51:57' ORDER BY starttime desc LIMIT 1 Driver error was [2/2013]: QMYSQL3: Unable to execute query Database error was: Lost connection to MySQL server during query

2008-03-10 22:51:57.820 MSqlQuery: SELECT channum, callsign, icon FROM channel WHERE chanid = 2082 2008-03-10 22:51:57.820 DB Error (GetNextProgram? -- get channel info): Query was: SELECT channum, callsign, icon FROM channel WHERE chanid = 2082 Driver error was [2/2006]: QMYSQL3: Unable to execute query Database error was: MySQL server has gone away

MYSQL Log:

080310 22:51:57 - mysqld got signal 11; This could be because you hit a bug. It is also possible that this binary or one of the libraries it was linked against is corrupt, improperly built, or misconfigured. This error can also be caused by malfunctioning hardware. We will try our best to scrape up some info that will hopefully help diagnose the problem, but since we have already crashed, something is definitely wrong and this may fail.

key_buffer_size=16777216 read_buffer_size=258048 max_used_connections=9 max_connections=100 threads_connected=7 It is possible that mysqld could use up to key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 3318383 K bytes of memory Hope that's ok; if not, decrease some variables in the equation.

thd=0x24292e0 Attempting backtrace. You can use the following information to find out where mysqld died. If you see no messages after this, something went terribly wrong... Cannot determine thread, fp=0x4414bfe0, backtrace may not be correct.

Stack range sanity check OK, backtrace follows: (nil) New value of fp=0x24292e0 failed sanity check, terminating stack trace! Please read http://dev.mysql.com/doc/mysql/en/using-stack-trace.html and follow instructions on how to resolve the stack trace. Resolved stack trace is much more helpful in diagnosing the problem, so please do resolve it Trying to get some variables.

Some pointers may be invalid and cause the dump to abort... thd->query at 0x262b450 = SELECT title, subtitle, description, category, starttime, endtime, callsign, icon, channum, seriesid, programid FROM program, channel WHERE program.chanid = channel.chanid AND channel.chanid = 2082 AND starttime <= '2008-03-10T22:51:57' ORDER BY starttime desc LIMIT 1

thd->thread_id=12 The manual page at http://www.mysql.com/doc/en/Crashing.html contains information that should help you find out what is causing the crash.

Please let me know what other diags. would be helpful.

Thanks!

Change History (1)

comment:1 Changed 12 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Not a mythtv bug.

Note: See TracTickets for help on using tickets.