Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#498 closed defect (fixed)

mythtv-setup DVB channel scan seg fault (rev 7534)

Reported by: mythtv-trac@… Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Doing a channel scan causes a segmentation fault. Using a HD-3000 ./configure --enable-xvmc --enable-opengl-vsync --enable-dvb --disable-xvmc-vld --compile-type=debug

Attaching log and backtrace.

Attachments (10)

backtrace.txt (10.5 KB) - added by mythtv-trac@… 14 years ago.
Log and backtrace of channel scan
backtrace (17.3 KB) - added by seth.lists@… 14 years ago.
backtrace.txt.txt (2.5 KB) - added by anonymous 14 years ago.
backtrace of 2005-10-25 myth cvs, segfault doing qam256 std cable channel scan with airstart2/hd5000 tuner
scan-dbg.patch (2.2 KB) - added by danielk 14 years ago.
debugging patch
bt-with-debug-patch.txt (39.1 KB) - added by mythtv-trac@… 14 years ago.
Backtrace with current svn and debug patch
mythtv-valgrind.txt.12338 (25.8 KB) - added by matthew.annen@… 14 years ago.
mythtv-setup full cable chan scan using valgrind with memory leak test=yes
gdb-1.txt (11.9 KB) - added by anonymous 14 years ago.
gdb-2.txt (12.0 KB) - added by anonymous 14 years ago.
mythtv-setup-1.txt (16.5 KB) - added by anonymous 14 years ago.
mythtv-setup-2.txt (20.8 KB) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (26)

Changed 14 years ago by mythtv-trac@…

Attachment: backtrace.txt added

Log and backtrace of channel scan

comment:1 Changed 14 years ago by seth.lists@…

Here is another backtrace, this time with rev. 7466 and an AirStar? HD card.

./configure --compile-type=debug --enable-dvb --enable-xvmc --enable-opengl-vsync --disable-joystick-menu

Attached backtrace below.

Changed 14 years ago by seth.lists@…

Attachment: backtrace added

Changed 14 years ago by anonymous

Attachment: backtrace.txt.txt added

backtrace of 2005-10-25 myth cvs, segfault doing qam256 std cable channel scan with airstart2/hd5000 tuner

Changed 14 years ago by danielk

Attachment: scan-dbg.patch added

debugging patch

comment:2 Changed 14 years ago by danielk

Can someone try the debugging patch and report back with the output of "mythtv-setup -v siparser,channel" and the backtrace from the crash?

Changed 14 years ago by mythtv-trac@…

Attachment: bt-with-debug-patch.txt added

Backtrace with current svn and debug patch

comment:3 Changed 14 years ago by mythtv-trac@…

I attached the log and backtrace. With this build, it didn't get as far as it did previously. Here, it seems to have crashed on the first channel lock. With the first backtrace I attached it crashed on about the 4th channel lock. Not sure if that matters. I hope this helps. Thanks.

comment:4 Changed 14 years ago by danielk

Milestone: 0.19
Version: head

Can you run this a 3-4 more times and produce different stacktraces? The last one had a corrupted stack.

Also if you know how to run Valgrind that might be even more helpful. This appears to be a corrupted memory problem.

comment:5 Changed 14 years ago by danielk

(In [7661]) References #498.

Adds a VERBOSE(VB_SIPARSER, ..) macro to ProgramMapTable::Parse()

comment:6 Changed 14 years ago by danielk

(In [7662]) References #498.

Adds some sanity checks on PMT table in SIScan::UpdatePATinDB().

comment:7 Changed 14 years ago by danielk

Milestone: 0.19unknown
Resolution: worksforme
Status: newclosed

I've committed a few sanity checks and a debugging macro.

Valgrind doesn't report anything for me, but it might for the people experiencing the SEGFAULTS.

Since I can't reproduce the problem and I'm not getting responses from the bug reporters anymore, I'm marking this as "worksforme"...

Changed 14 years ago by matthew.annen@…

Attachment: mythtv-valgrind.txt.12338 added

mythtv-setup full cable chan scan using valgrind with memory leak test=yes

comment:8 Changed 14 years ago by matthew.annen@…

I ran mythtv-setup using valgrind. Above I have attached the output. Mythtv-setup segfaulted during scan. -matt

comment:9 Changed 14 years ago by danielk

Resolution: worksforme
Status: closedreopened

Matt, can you create some backtraces too?

If they all look the same, just send me the one. But since this appears to be a memory problem, they might be different.

Unfortunately, I couldn't find anything useful in the valgrind output.

comment:10 Changed 14 years ago by matthew.annen@…

I ran mythtv-setup twice using the command line args you mentioned above. I ran a full qam256 cable scan. Both times the scan crashed at what seems to me to be the same point in the scan, at C105 somewhere. I hope my traces are of some use. I copied some of the corresponding console output from mythtv-setup, too. The files are paired above. Thanks.

-matt

Changed 14 years ago by anonymous

Attachment: gdb-1.txt added

Changed 14 years ago by anonymous

Attachment: gdb-2.txt added

Changed 14 years ago by anonymous

Attachment: mythtv-setup-1.txt added

Changed 14 years ago by anonymous

Attachment: mythtv-setup-2.txt added

comment:11 Changed 14 years ago by matthew.annen@…

FYI, I was using rev 7662.

-matt

comment:12 Changed 14 years ago by matthew.annen@…

Wow, I was able to get a few of the FTA channels on the scan at least. This looks GREAT!

comment:13 Changed 14 years ago by mythtv-trac@…

I'll get you some more backtraces and valgrind output, but it will be a couple more days before I can get to it. Thanks for looking in to this.

comment:14 Changed 14 years ago by danielk

It looks like the problem has to do with DVB tables showing up in an unexpected place. I'll add some debugging for this...

Just to satisfy my curiosity, are you in North America?

comment:15 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [7690]) Fixes #498.

There was an indexing problem in handling NIT tables. This was being seen unexpectedly during an ATSC (QAM) scan; but this should also fix at least part of the problems seen when disabling the SIParser during channel scanning.

comment:16 Changed 14 years ago by mythtv-trac@…

Fixed it for me THANKS!!!! ... and yes, I'm in North America..

Note: See TracTickets for help on using tickets.