Opened 12 years ago

Closed 12 years ago

#5006 closed patch (wontfix)

Fix for mythweb flash streaming to allow it to work with mpeg-4 .nuv

Reported by: scottadmi@… Owned by: xris
Priority: minor Milestone: 0.21.1
Component: mythweb Version: 0.21-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

I was consistently getting the an error when I tried to stream flash video from any NuppleVideo? MPEG-4 recording within mythtv (though the mpeg2 streams worked fine). After several seconds of transcoding the following error was reported by ffmpeg:

Marker bit missing before time_increment_resolution8 bitrate= 384.0kbits/s [mpeg4 @ 0xb7dbc6e8]time_base.den==0 [mpeg4 @ 0xb7dbc6e8]header damaged Error while decoding stream #0.0 Floating point exception

I did some exploration and found that mencoder (part of mplayer) did a good job. I've included a patch for a modified version of the mythweb/modules/stream/handler.pl which replicates the original behavior but uses mencoder rather than ffmpeg. A flag at the top determines which is used.

Attachments (1)

handler.pl.patch (2.7 KB) - added by scottadmi@… 12 years ago.
Patch for mythweb/modules/stream/handler.pl

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by scottadmi@…

Attachment: handler.pl.patch added

Patch for mythweb/modules/stream/handler.pl

comment:1 Changed 12 years ago by sphery <mtdean@…>

Dup of #4181

comment:2 Changed 12 years ago by xris

Resolution: wontfix
Status: newclosed

Patch for unsupported feature.

Note: See TracTickets for help on using tickets.