Opened 12 years ago

Closed 12 years ago

#5022 closed defect (fixed)

upcoming recordings page unusably slow

Reported by: Tony Lill <ajlill@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you turn on more than the default of Scheduled and Conflict, on this screen, then it can take 10s of minutes, or even hours to complete. During this time the browser consumes 100% of the CPU, and is otherwise rendered practically useless. It can also pop up a continuous stream of script timeout messages.

After a considerable amount of experimenting, I've concluded that the root cause is that mythweb gernerates the following bit of javascript for each program listed. Keep in mind that turning on just Deactivated brings the program count to nearly 1000, everything brings the count to 3500.

<script type="text/javascript">new Tip($("program_26"), "<dl class='details_list'> ... /dl>", { className: "popup" });</script>

This page should either be updated to use the ajax method from the program listing page, or reverted to the method used in 0.20, which is several hundred times faster.

Change History (2)

comment:1 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newassigned

comment:2 Changed 12 years ago by Rob Smith

Resolution: fixed
Status: assignedclosed

([17558]) Fixes #5022, Updates the upcoming recordings page to use the ajax loader for the popups

Note: See TracTickets for help on using tickets.