Opened 12 years ago

Closed 12 years ago

#5051 closed defect (fixed)

Cannot create new database SVN Revsion 16814

Reported by: harpax Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythTV changes the database character set from latin1 when it is created to UTF8 while upgrading the schema, then attempts to create a primary key > 1000 bytes (128+255) bytes * 3 (for UTF8) = 1149 bytes total. The schema upgrade always fails due to the length of the key.

Procedure to reproduce:

  1. Create the database with mysql -u root < mc.sql
  2. run mythtv-setup

Database character set before running mythtv-setup:
mysql> show variables like "character_set_database";

character_set_database latin1

Database character set after running mythtv-setup:
mysql> show variables like "character_set_database";

character_set_database utf8

Change History (3)

comment:1 Changed 12 years ago by harpax

I wanted to include the output of mythtv-setup with the ticket, but trac keeps rejecting it as spam. It wouldn't even allow me to attach it as a text file.

comment:2 Changed 12 years ago by Janne Grunau

Milestone: unknown0.22
Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned
Version: unknownhead

comment:3 Changed 12 years ago by Janne Grunau

Resolution: fixed
Status: assignedclosed

(In [16818]) the initial database has to use latin1 as default character set. Closes #5051

Note: See TracTickets for help on using tickets.