Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#5183 closed defect (duplicate)

Guide unresponsive when realtime priority threads are enabled

Reported by: geoffp@… Owned by: Isaac Richards
Priority: minor Milestone: 0.21.1
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When realtime priority playback threads are enabled, the guide becomes extremely unresponsive to user input. User input breaks through after a 20-40 second delay.

This happens for me on a slower machine: a 1.6gHz Sempron 64, on which during standard-def playback (with yadif 2x) mythfrontend pulls about 58% CPU, and idle times hovering around 20%.

However, this also happens with bob 2x, which relaxes the CPU load quite a bit (down to 22% CPU, ~60% idle).

Nothing unusual appears in the mythfrontend log.

Change History (7)

comment:1 Changed 11 years ago by nigel.jewell@…

To clarify - are you stating that if realtime priority threads are disabled that this problem disappears? I am seeing something very similar.

comment:2 Changed 11 years ago by anonymous

Nigel: that is exactly right. There is no problem if realtime priority threads are disabled.

comment:3 Changed 11 years ago by nigel.jewell@…

Geoff - yep, I am seeing this as well, but the guide seems to hang indefinately. Removing realtime threads made the guide work (in the sense it doesn't hang), although the whole experience of using the guide with live preview isn't great. It is definitely slower in 0.21 than in 0.20.

It would be nice to have realtime threads enabled, with a guide that doesn't hang.

For reference, this is on a 2GHz Sempron

comment:4 Changed 11 years ago by laga

Status: newinfoneeded_new

#3986 might contain a workaround. Can you test if disabling the deinterlacer helps with your issue?

comment:5 Changed 11 years ago by nigel.jewell@…

Yep, #18547 resolves this for me. The guide is usable again.

comment:6 Changed 11 years ago by laga

Resolution: duplicate
Status: infoneeded_newclosed

Neat. Closing this. Duplicate of #3986.

comment:7 Changed 11 years ago by nigel.jewell@…

Of course, I meant r18547.

Note: See TracTickets for help on using tickets.