Opened 12 years ago

Closed 12 years ago

#5348 closed defect (wontfix)

Scheduler scheduled a previously recorded program

Reported by: anonymous Owned by: bjm
Priority: minor Milestone: unknown
Component: scheduler Version: 0.21
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi All,

Myth is great! Here's my issue: A MADtv episode is scheduled for later today, but I don't think it should be since duplicate is 1, recstatus is -3 and the program and show ids are the same. The wrinkle might be that the episode was original recorded with a vanilla record all episodes rule, and now I'm using a custom power search.

Here's mythbackend --printsched:

Title - Subtitle Ch Station Day Start End S C I T N Pri

MADtv 49 COMEDY 12 13:00-14:00 1 2 2 A 2 1/0

Here is the row in the program table: mysql> select * from program where programid = 'EP001547960087'; +--------+---------------------+---------------------+-------+----------+----------------------------------------------------------------------------------+----------+---------------+---------+-------+-----------------+-----------------+--------+-----------+------+----------------+------------+-----------+------------+-----------------+----------+-----------+-------------------------+----------------+----------+---------+---------------+-------+------+-----------+---------------+-----------+ | chanid | starttime | endtime | title | subtitle | description | category | category_type | airdate | stars | previouslyshown | title_pronounce | stereo | subtitled | hdtv | closecaptioned | partnumber | parttotal | seriesid | originalairdate | showtype | colorcode | syndicatedepisodenumber | programid | manualid | generic | listingsource | first | last | audioprop | subtitletypes | videoprop | +--------+---------------------+---------------------+-------+----------+----------------------------------------------------------------------------------+----------+---------------+---------+-------+-----------------+-----------------+--------+-----------+------+----------------+------------+-----------+------------+-----------------+----------+-----------+-------------------------+----------------+----------+---------+---------------+-------+------+-----------+---------------+-----------+ | 1049 | 2008-05-12 15:30:00 | 2008-05-12 16:30:00 | MADtv | | "Talkin' American: Monica"; "Oh, Hercules"; guests Kevin Sorbo and Gary Coleman. | Comedy | series | 0000 | 0 | 1 | | 1 | 0 | 0 | 1 | 0 | 0 | EP00154796 | 1998-10-10 | Series | | 405 | EP001547960087 | 0 | 0 | 0 | 1 | 0 | STEREO | HARDHEAR | | | 1049 | 2008-05-13 13:00:00 | 2008-05-13 14:00:00 | MADtv | | "Talkin' American: Monica"; "Oh, Hercules"; guests Kevin Sorbo and Gary Coleman. | Comedy | series | 0000 | 0 | 1 | | 1 | 0 | 0 | 1 | 0 | 0 | EP00154796 | 1998-10-10 | Series | | 405 | EP001547960087 | 0 | 0 | 0 | 0 | 1 | STEREO | HARDHEAR | | +--------+---------------------+---------------------+-------+----------+----------------------------------------------------------------------------------+----------+---------------+---------+-------+-----------------+-----------------+--------+-----------+------+----------------+------------+-----------+------------+-----------------+----------+-----------+-------------------------+----------------+----------+---------+---------------+-------+------+-----------+---------------+-----------+ 2 rows in set (0.02 sec)

And here is the row from the oldrecorded table: mysql> select * from oldrecorded where programid = 'EP001547960087'; +--------+---------------------+---------------------+--------+----------+----------------------------------------------------------------------------------+----------+------------+----------------+--------+----------+---------+---------+-----------+-----------+------------+---------+ | chanid | starttime | endtime | title | subtitle | description | category | seriesid | programid | findid | recordid | station | rectype | duplicate | recstatus | reactivate | generic | +--------+---------------------+---------------------+--------+----------+----------------------------------------------------------------------------------+----------+------------+----------------+--------+----------+---------+---------+-----------+-----------+------------+---------+ | 1049 | 2007-12-28 16:00:00 | 2007-12-28 17:00:00 | MAD TV | | "Talkin' American: Monica"; "Oh, Hercules"; guests Kevin Sorbo and Gary Coleman. | Comedy | EP00154796 | EP001547960087 | 0 | 963 | COMEDY | 4 | 1 | -3 | 0 | 0 | +--------+---------------------+---------------------+--------+----------+----------------------------------------------------------------------------------+----------+------------+----------------+--------+----------+---------+---------+-----------+-----------+------------+---------+

Thanks!

Attachments (1)

titledup1.patch (1.7 KB) - added by gigem 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by anonymous

Sorry - I copied the wrong line from the --printsched call here's the correct one:

MADtv 49 COMEDY 12 15:30-16:30 1 2 2 A 2 1/0

comment:2 Changed 12 years ago by gigem

Status: newinfoneeded_new

It looks like the 13:00 and 15:30 showings are both set to record. Are you sure you didn't turn off duplicate checking in your recording rule?

comment:3 in reply to:  2 ; Changed 12 years ago by anonymous

How can I check if duplicate checking is turned off? MythWEB shows the duplicate checking method as "Subtitle and Description" if that helps.

Thanks Again!

comment:4 in reply to:  3 Changed 12 years ago by gigem

Replying to anonymous:

How can I check if duplicate checking is turned off? MythWEB shows the duplicate checking method as "Subtitle and Description" if that helps.

It's probably set correctly, then, but to be sure, please check using mythfrontend. Go to "Manage Recordings" > "Upcoming Recordings", press INFO (default "I") on of the MADtv entries set to record, then choose "Scheduling Options" and look at the "Match duplicates..." and "Look for duplicates..." lines.

comment:5 Changed 12 years ago by anonymous

I can confirm that "Match Duplicates..." says "Match duplicates in current and previous recordings" and "Look for duplicates..." says "Look for duplicates in current and previous recordings"

Any ideas what could be the issue?

comment:6 Changed 12 years ago by anonymous

Now that it recorded, the only differences I can see in the rows in oldrecorded table are:

  1. The title changed from "MAD TV" to "MADtv"
  2. The recordid changed from 963 to 1077

Thanks again!

Changed 12 years ago by gigem

Attachment: titledup1.patch added

comment:7 in reply to:  6 Changed 12 years ago by gigem

Resolution: wontfix
Status: infoneeded_newclosed

Replying to anonymous:

Now that it recorded, the only differences I can see in the rows in oldrecorded table are:

  1. The title changed from "MAD TV" to "MADtv"
  2. The recordid changed from 963 to 1077

I totally missed the change in titles. That is the root cause of the problem. Are you using EIT? I am attaching a patch which should fix this.

I will NOT be committing this patch to SVN since it increases the scheduler run times for me by almost an order of magnitude. Until the duplicate checking queries in the scheduler can be refactored or optimized, we'll just have to live with this particular and fairly obscure bug.

Note: See TracTickets for help on using tickets.