Opened 12 years ago

Closed 10 years ago

#5352 closed defect (invalid)

Recordings randomly fail: Recording will not commence until a PMT is set.

Reported by: chris@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - ATSC Version: 0.21-fixes
Severity: medium Keywords: PMT air2pc dvb recording fail
Cc: Ticket locked: no

Description

Version: 0.21.0+fixes16838-0ubuntu3

I have been seeing recordings fail with an error message that was supposed to have gone away ages ago. I've got two Air2PC cards that have been working fine for over a year, and up until Hardy I've never seen this problem.

Other recordings on this channel occur fine, just once in a while I'll see this error.

2008-05-12 20:59:29.866 TVRec(1): ASK_RECORDING 1 29 0 0
2008-05-12 21:00:00.994 TVRec(1): Changing from RecordingOnly to None
2008-05-12 21:00:02.929 Using runtime prefix = /usr, libdir = /usr/lib
2008-05-12 21:00:02.954 Empty LocalHostName.
2008-05-12 21:00:02.958 Using localhost value of cwawak-desktop
2008-05-12 21:00:03.140 New DB connection, total: 1
2008-05-12 21:00:03.178 Connected to database 'mythconverg' at host: localhost
2008-05-12 21:00:03.215 Closing DB connection named 'DBManager0'
2008-05-12 21:00:03.218 Connected to database 'mythconverg' at host: localhost
2008-05-12 21:00:03.221 New DB connection, total: 2
2008-05-12 21:00:03.223 Connected to database 'mythconverg' at host: localhost
2008-05-12 21:00:03.224 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 8 min
2008-05-12 21:00:03.238 Current Schema Version: 1214
2008-05-12 21:00:03.441 TVRec(1): Changing from None to RecordingOnly
2008-05-12 21:00:03.452 DTVSM(1) Error: Wrong PMT; pmt->pn(3) desired(1)
2008-05-12 21:00:03.483 Program #1 not found in PAT!
Program Association Table
 PSIP tableID(0x0) length(13) extension(0x9bf)
      version(1) current(1) section(0) last_section(0)
         tsid: 2495
 programCount: 1
  program number     3 has PID 0x  30   data  0x 0 0x 3 0xe0 0x30

2008-05-12 21:00:03.484 But there is only one program in the PAT, so we'll just use it
2008-05-12 21:00:03.481 TVRec(1): HW Tuner: 1->1
2008-05-12 21:00:03.943 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 8 min
2008-05-12 21:00:03.949 Started recording: House "House's Head": channel 1291 on cardid 1, sourceid 1
2008-05-12 21:00:04.745 Could not find channel 29_1 in TVCT
2008-05-12 21:00:04.750 
VCT Terra: channels(1) tsid(0x9b7) seclength(68)
Channel #0 name(KYW-DT) 3-1 mod(ATSC 8-VSB) cTSID(0x9b7)
 pnum(1) ETM_loc(0) access_ctrl(0) hidden(0) hide_guide(1) service_type(2) source_id(1)
 descriptors length(23) count(1)
  Service Location Descriptor (0xa1) length(21)


2008-05-12 21:00:04.906 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.
2008-05-12 21:00:04.957 Reschedule requested for id 0.
2008-05-12 21:00:04.964 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.
2008-05-12 21:00:05.051 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.
2008-05-12 21:00:05.137 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.
2008-05-12 21:00:05.197 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.
2008-05-12 21:00:05.255 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.
2008-05-12 21:00:05.311 DVBRec(1:0) Warning: Recording will not commence until a PMT is set.

... and so on until 22:00:00.

If I can assist with any other information, please let me know.

Attachments (6)

mythbackend.PMTnotSet.07072008.log (153.3 KB) - added by ianicbrisson@… 12 years ago.
PMT not set log
log.txt (1.7 KB) - added by wakeboarder 11 years ago.
log file
channel.sql (4.2 KB) - added by wakeboarder 11 years ago.
channel dump
dtv_multiplex.sql (3.4 KB) - added by wakeboarder 11 years ago.
dtv_multiplex dump
debuglog.txt (64.8 KB) - added by wakeboarder 11 years ago.
debug backend logs
backendlogs.zip (200.1 KB) - added by wakeboarder 11 years ago.
backend log

Download all attachments as: .zip

Change History (20)

Changed 12 years ago by ianicbrisson@…

PMT not set log

comment:1 Changed 12 years ago by ianicbrisson@…

I am also experiencing this problem. Ticket 5507 shows the same symtpoms. Ticket 3031 which was closed a while back also seems to be related. There also is a bug opened under Ubuntu: https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/229797

Typically, one recording out of three will not work. The recording file exist but is empty and after checking the log I get the "Warning: Recording will not commence until a PMT is set." message.

Current OS level: Ubuntu 7.10 (Gutsy) Kernel: 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux Mythtv Level: 0.21.0-0ubuntu2~gutsy1 - Architecure: amd64 DVB card: Air2PC First Gen I had the same problem with 0.20-0.4 from which I upgraded and on a Fusion HDTV Gold which I replaced because I thought it was a hardware problem. Here's the complete information about the mythtv version: MythTV Version : 16468 MythTV Branch : tags/release-0-21 Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in: linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

Log file is attached as mythbackend.PMTnotSet.07072008.log.

I can't tell the source of the problem but this appears to me as a high priority bug as it affects the core fucntionality of mythtv.

I'll be happy to help with any additionnal information.

comment:2 Changed 12 years ago by jheizer@…

Same thing just happened to me tonight for the first time ever. I also noticed the machine had ate up the entire 1GB of ram. Not sure if myth was the cause or not. It was dumping those errors for 2 hours.

2008-07-16 18:59:24.867 TVRec(5): ASK_RECORDING 5 29 0 0
2008-07-16 18:59:24.868 TVRec(4): ASK_RECORDING 4 29 0 0
2008-07-16 18:59:25.328 TVRec(2): ASK_RECORDING 2 29 0 0
2008-07-16 18:59:25.335 TVRec(3): ASK_RECORDING 3 29 0 0
2008-07-16 18:59:56.570 TVRec(2): Changing from None to RecordingOnly
2008-07-16 18:59:56.587 TVRec(2): HW Tuner: 2->2
2008-07-16 18:59:56.650 AutoExpire: CalcParams(): Max required Free Space: 6.0 GB w/freq: 15 min
2008-07-16 18:59:56.655 Started recording: So You Think You Can Dance: channel 2431 on cardid 2, sourceid 2
2008-07-16 18:59:56.662 scheduler: Started recording: So You Think You Can Dance: channel 2431 on cardid 2, sourceid 2
2008-07-16 18:59:57.045 DTVSM(0) Error: Wrong PMT; pmt->pn(3) desired(4)
2008-07-16 18:59:57.050 Could not find channel 43_1 in CVCT
2008-07-16 18:59:57.051
VCT Cable: channels(3) tsid(0x804e) seclength(109)
Channel #0 name(WHOI-DT) 19-1 mod(ATSC 8-VSB) cTSID(0x804e)
 pnum(3) ETM_loc(1) access_ctrl(0) hidden(0)
path_select(1) out_of_band(1) hide_guide(1) service_type(2) source_id(1)

Channel #1 name(WEEK-SD) 25-2 mod(ATSC 8-VSB) cTSID(0x804e)
 pnum(4) ETM_loc(0) access_ctrl(0) hidden(0)
path_select(1) out_of_band(1) hide_guide(1) service_type(2) source_id(2)

Channel #2 name(WEEK-HD) 25-1 mod(ATSC 8-VSB) cTSID(0x804e)
 pnum(1) ETM_loc(0) access_ctrl(0) hidden(0)
path_select(1) out_of_band(1) hide_guide(1) service_type(2) source_id(3)


2008-07-16 18:59:57.217 DVBRec(2:0) Warning: Recording will not commence until a PMT is set.
2008-07-16 18:59:57.281 DVBRec(2:0) Warning: Recording will not commence until a PMT is set.
2008-07-16 18:59:57.342 DVBRec(2:0) Warning: Recording will not commence until a PMT is set.

comment:3 Changed 11 years ago by ianicbrisson@…

Is there anybody working on the issue? Because of the lack of reliable HD recording and under the perssure of my "users", I am conteplating moving to the local cable services or moving back to Windows and a commercial PVR solution. I don't like the idea but 90% of our recordings are in HD and we never know if they are going to work or not.

Thank you

Ianic Brisson

comment:4 Changed 11 years ago by blammo@…

Seeing this problem myself. Centos5 32-bit SBE w/4 air2pc cards, running 2.6.18-92.1.10.el5, and myth* from atrpms via yum.

[root@tuners ~]# mythbackend --version Please include all output in bug reports. MythTV Version : 17961M MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

comment:5 Changed 11 years ago by danielk

Status: newinfoneeded_new

Please provide full logs using "-v record,siparser,channel" for mythbackend + a dump of your channel and dtv_multiplex tables.

Changed 11 years ago by wakeboarder

Attachment: log.txt added

log file

Changed 11 years ago by wakeboarder

Attachment: channel.sql added

channel dump

Changed 11 years ago by wakeboarder

Attachment: dtv_multiplex.sql added

dtv_multiplex dump

comment:6 Changed 11 years ago by wakeboarder

Just added logs and dumps, however didn't yet have the debugging option set before this happened, so turned that on now. Running fedora 8 on 64 bit system with 2 air2pc HD capture cards.

Changed 11 years ago by wakeboarder

Attachment: debuglog.txt added

debug backend logs

comment:7 Changed 11 years ago by anonymous

This has happened to me about once a week, is there any more debugging code I can provide? If someone has some debug code, I can attempt running it to provide more details.

comment:8 Changed 11 years ago by wakeboarder

Saw an interesting thing, is that one of my two Air2pc cards had the PMT error on a recording on Nov 10th at 4PM which completely missed the Oprah show for my wife.. But without me touching anything on the box, was able to record two shows at 10:30 AM on Nov 11'th. So it seems that the cards can reset themselves, but someone mythtv code needs to detect this PMT card and try the next tuner or wait and retry in a better way. Uploading the backend log that shows the failure and recovery in case there are clues in there.

Changed 11 years ago by wakeboarder

Attachment: backendlogs.zip added

backend log

comment:9 Changed 11 years ago by Dibblah

Status: infoneeded_newnew

comment:10 Changed 11 years ago by Dibblah

Status: newassigned

comment:11 Changed 11 years ago by ddempsey3

This just happened to me when I was in the middle of a recording. When I restarted the backend the recording started without issues on the same turner that was having issues before the restart.

I am running Ubuntu Hardy. MythTV Version : 18722 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

comment:12 Changed 10 years ago by stuartm

Component: dvbMythTV - ATSC

comment:13 Changed 10 years ago by mythtv@…

Hi,

This happened for me now, never seen it before today and I have used MythTV for 2 years now. Currentl running mythbackend version: branches/release-0-22-fixes [23110M].

Couple of days ago I activated EIT scan on my second DVB-C card, could this maybe be related?

comment:14 Changed 10 years ago by stuartm

Resolution: invalid
Status: assignedclosed

Driver bugs. Please report to the appropriate place if you continue to have problems.

Note: See TracTickets for help on using tickets.