Opened 12 years ago

Closed 11 years ago

#5396 closed defect (invalid)

Audio stuttering when video is paused

Reported by: mythdev@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by paulh)

When I pause my video, the audio starts stuttering. So a very annoying sound is made. When I resume the video everything is normal again until I pause the video.

Also when skipping the sound can be heard a very limited time. It is a repeating "tick".

It worked until about 2 weeks ago. I always follow SVN as close as possible, but I do not yet know what commit broke this for me.

I use an epia as frontend, that may be relevant (or not).

The frontend log shows the following:

[...]
2008-05-26 08:31:25.252 TV: Attempting to change from None to WatchingPreRecorded
2008-05-26 08:31:25.423 DPMS Deactivated 
2008-05-26 08:31:26.761 AFD: Opened codec 0x83b1d80, id(MPEG2VIDEO_XVMC_VLD) type(Video)
2008-05-26 08:31:26.762 AFD: codec MP2 has 2 channels
2008-05-26 08:31:26.762 AFD: Opened codec 0x923d250, id(MP2) type(Audio)
2008-05-26 08:31:26.808 Opening audio device 'default'. ch 2(2) sr 48000
2008-05-26 08:31:26.822 Opening ALSA audio device 'default'.
2008-05-26 08:31:27.694 VideoOutputXv: XvMC Adaptor Name: 'XV_SWOV'
Unable to create XvMC Surface.
2008-05-26 08:31:27.738 OSD Theme Dimensions W: 640 H: 480
2008-05-26 08:31:37.652 TV: Changing from None to WatchingPreRecorded
[...]
2008-05-26 08:27:43.944 WriteAudio: buffer underrun
2008-05-26 08:27:43.984 WriteAudio: buffer underrun
2008-05-26 08:27:44.024 WriteAudio: buffer underrun
2008-05-26 08:27:44.064 WriteAudio: buffer underrun
2008-05-26 08:27:44.104 WriteAudio: buffer underrun
2008-05-26 08:27:44.154 WriteAudio: buffer underrun
2008-05-26 08:27:44.194 WriteAudio: buffer underrun
2008-05-26 08:27:44.244 WriteAudio: buffer underrun
[...]

Please include all output in bug reports.
MythTV Version   : 17392
MythTV Branch    : trunk
Library API      : 0.22.20080512-2
Network Protocol : 40
QT Version       : 4.3.4
Options compiled in:
 linux release using_alsa using_backend using_frontend using_lirc using_v4l using_x11 using_xv using_xvmc using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads

00:00.0 Host bridge: VIA Technologies, Inc. VT8623 [Apollo CLE266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo CLE266] integrated CastleRock graphics (rev 03)

Sound Modules:

snd_via82xx            18676  0
snd_ac97_codec         84224  1 snd_via82xx
ac97_bus                1344  1 snd_ac97_codec
snd_pcm                52488  2 snd_via82xx,snd_ac97_codec
snd_page_alloc          6824  2 snd_via82xx,snd_pcm
snd_mpu401_uart         5376  1 snd_via82xx
snd_rawmidi            14496  1 snd_mpu401_uart

Change History (4)

comment:1 Changed 12 years ago by mythdev@…

Michael T. Dean wrote:

Are you sure you have a valid seektable?  optimize_mythdb.pl, then--assuming hardware-encoded/digitally-broadcast MPEG--use mythtranscode --buildindex (look up the proper command line on the archives, as it takes more than I've given and just what I showed won't fix anything).

I run the optimize_mythdb.pl in a cron job every day. All recordings suffer from the exact same symptoms.

It worked until about 2 weeks ago. I always follow SVN as close as

possible,

even when it involves running code that's not yet ready for production use, it seems.

This is correct, I use SVN to test MythTV and report problems I see, isn't this the idea of running SVN? I am not complaining, I am just trying to help diagnose problems. If this is not appreciated, please tell me so, and I will stop bugging you all.

Mike

Regards,

Daan de Beer

comment:2 in reply to:  1 ; Changed 12 years ago by paulh

Description: modified (diff)
Version: unknownhead

Replying to mythdev@tiscali.nl:

This is correct, I use SVN to test MythTV and report problems I see, isn't this the idea of running SVN? I am not complaining, I am just trying to help diagnose problems. If this is not appreciated, please tell me so, and I will stop bugging you all.

I wouldn't recommend anyone use svn trunk on a production machine at the moment. I like a lot of people have for the first time since using Myth have had to switch to the fixes branch. There is just too many subtle and some not so subtle bugs caused by the switch to Qt4 and also the new UI stuff is often breaking things at the moment.

Having said all that of cause we want people to test trunk and report bugs otherwise it will never become stable again.

As for your problem could be something to do with this commit? http://cvs.mythtv.org/trac/changeset/17251

Also does toggling 'Extra audio buffering' have any effect?

comment:3 in reply to:  2 Changed 12 years ago by anonymous

Replying to paulh:

Replying to mythdev@tiscali.nl:

This is correct, I use SVN to test MythTV and report problems I see, isn't this the idea of running SVN? I am not complaining, I am just trying to help diagnose problems. If this is not appreciated, please tell me so, and I will stop bugging you all.

I wouldn't recommend anyone use svn trunk on a production machine at the moment. I like a lot of people have for the first time since using Myth have had to switch to the fixes branch. There is just too many subtle and some not so subtle bugs caused by the switch to Qt4 and also the new UI stuff is often breaking things at the moment.

Having said all that of cause we want people to test trunk and report bugs otherwise it will never become stable again.

As for your problem could be something to do with this commit? http://cvs.mythtv.org/trac/changeset/17251

Also does toggling 'Extra audio buffering' have any effect?

I disabled the aggressive audio buffering and the problem went away. Is this intended behavior? Or can I somehow help debug this problem?

Thank you all for your help.

comment:4 Changed 11 years ago by stuartm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.