Modify

Opened 10 years ago

Closed 9 years ago

#5543 closed defect (worksforme)

"Off air" screen still displayed when channels comes "on air"

Reported by: Ash Bostock <abostock@…> Owned by: stuartm
Priority: minor Milestone: 0.21.1
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In the UK we have several channels on Freeview which are only available between certain times. During the "off air" hours myth correctly displays the MHEG page showing when that channel will be back "on air".

I have a recent recording which was the first "on air" timeslot for that day and when playing it back it displays the "off air" MHEG page during the whole thing while the actual show is playing in the background.

I haven't yet tested it on another new recording (to see if it does the same thing again) but can do so if required.

Attachments (0)

Change History (7)

comment:1 Changed 10 years ago by stuartm

  • Milestone changed from unknown to 0.21.1
  • Status changed from new to infoneeded_new

For reference, this was first fixed nearly two years ago with this commit - http://svn.mythtv.org/trac/changeset/11598

I can only assume there has been a regression since or that the channel in question has changed their methods or it was just a one off broadcast error.

It would be helpful if someone could confirm this is a repeatable problem, name the channel in question and be prepared to provide a sample recording.

comment:2 Changed 10 years ago by Ash Bostock <abostock@…>

I'll try with a few more recordings to see if it does the same thing again and report back. The recording mentioned in the ticket was from UK TV History.

comment:3 Changed 10 years ago by Ash Bostock <abostock@…>

Tried another recording this morning (on the same channel) and the same problem occurred. In terms of providing a sample recording what is the best way of doing that being that the resulting files are quite large? Should I cut a current recording down to a few seconds/minutes, if so what tool to use for that? or should I just setup a manual 1min schedule instead? Also any suggestions where I can host such a file?

Thanks.

comment:4 Changed 9 years ago by stuartm

  • Status changed from infoneeded_new to new

comment:5 Changed 9 years ago by Dibblah

  • Owner changed from ijr to stuartm
  • Status changed from new to assigned

comment:6 Changed 9 years ago by David Matthews <dm@…>

I've only just had a chance to look at this but I can't reproduce it on recordings of UK TV History coming on air made over the last few days. A recording made with 0.21 did not show any off-air logo at all and simply started with the programme. This is probably because with 0.21 there is no timing information when there are just DSMCC tables and no video or audio. I also tested by recording with 0.20 which records a "dummy video" stream along with the DSMCC. This does play the off-air logo until the programme begins. However, when played using 0.21 the off-air logo is correctly cleared when the programme begins as a result of the changes added in changeset 11598.

It is possible that the way the broadcaster signals coming on-air has changed since this was reported but unless this can be demonstrated with the current version of Myth I'm reluctant to investigate further.

David

comment:7 Changed 9 years ago by stuartm

  • Resolution set to worksforme
  • Status changed from assigned to closed

I can't reproduce this either.

Add Comment

Modify Ticket

Action
as closed The owner will remain stuartm.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.