Opened 11 years ago

Closed 11 years ago

#5611 closed defect (worksforme)

Mythmusic (mythfrontend) locks up when new song selected

Reported by: anonymous Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythmusic Version: 0.21-fixes
Severity: high Keywords: mythmusic mythfrontend freeze lockup
Cc: Ticket locked: no

Description

I'm running mythmusic on 64bit Ubuntu 8.04. Mythfrontend (in Mythmusic screen) locks up when I do the following:

  1. I start up Mythmusic from the "Listen to music" icon on the Mythfrontend screen.
  1. I pause the first song in my playlist - as soon as I get into Mythmusic the first song in the active playlist starts playing automatically (another bug?), since I want to listen to a different song I pause it and navigate to the song I want.
  1. I press select on another song while the first song remains paused.
  1. Mythfrontend locks up. I have to kill it with "killall -1 mythfrontend.real" at a terminal. THen restart it. THis happens every time I go through the sequence above. It seems to happen only after I initially start Mythmusic.

Version information from "mythfrontend --version":

MythTV Version : 16838

MythTV Branch : branches/release-0-21-fixes

Library API : 0.21.20080304-1

Network Protocol : 40

Options compiled in:

linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

Change History (1)

comment:1 Changed 11 years ago by paulh

Resolution: worksforme
Status: newclosed

I can't reproduce this in either trunk or fixes branch.

If you still have a problem you will have to capture a backtrace when the FE is locked then reopen this ticket with the bt attached:-

http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Note: See TracTickets for help on using tickets.