Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#5744 closed patch (wontfix)

Initial tuning to an analogue station fault

Reported by: anonymous Owned by: janne
Priority: major Milestone: 0.21.1
Component: mythtv Version: 0.21-fixes
Severity: medium Keywords: analog analogue
Cc: gnome42 Ticket locked: no

Description

When initiating a tv session, initial tuning to an analogue
channel fails. All that is produced is noise rather than
a picture.

The fault has been located in:
void TVRec::TuningNewRecorder?(MPEGStreamData *streamData)
Line 4002 CloseChannel?()

CloseChannel? here is called with with the only file descriptor
open on the video device. On certain tv cards at least, closing
that single connection will initiate and a sleep state of
the analogue frontend with loss of all previous tuning detail.
In order to fix this, the CloseChannel? call is moved to a later
point where it is known that the video device has been opened
for reading elsewhere.

Testing results in success and inspection of file descriptors
in use by the backend before and after shows no leakage.

Attachments (1)

TVRec_TuningNewRecorder_mythtv-0.21-fixes-18432.diff (665 bytes) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by gnome42

  • Cc gnome42 added
  • Status changed from new to assigned

I have applied this patch and it works fine with my bttv (V4L2) and pvr250.

I think it also solves a problem I had with the bttv card seeing a second or two of static when first tuning livetv. It also may solve a problem where I only got a black screen on ~ 1/20 livetv startup attempts, I have not been able to reproduce that problem in ~40 attempts with the patch applied.

BTW: The #ifdef USING_V4L appears redundant, GetV4LChannel() has the USING_V4L check.

comment:2 Changed 5 years ago by janne

  • Owner changed from ijr to janne
  • Status changed from assigned to accepted

comment:3 Changed 5 years ago by janne

  • Status changed from accepted to infoneeded

on trunk after [19250] it seems to have the different effect. I got a green screen on the first tuning attempt.

comment:4 Changed 5 years ago by danielk

  • Resolution set to wontfix
  • Status changed from infoneeded to closed

Info needed but not provided.

This looks like a workaround for broken V4L drivers, should be fixed upstream first, then we can add a workaround for the specific broken driver with version check. That way the hack can easily be removed when all major distros have been shipping non-broken drivers sufficiently long.

comment:5 Changed 5 years ago by patrick@…

I also have the problem described in this issue. Is there any other workaround or do I need to patch mythtv?

comment:6 Changed 5 years ago by patrick@…

I applied the patch to 0.22 and everything works fine with (HVR-4000)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.