Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#6022 closed defect (invalid)

DVB-T: encrypted OK, FTA no lock

Reported by: Octavian Petre <octavsly@…> Owned by: Isaac Richards
Priority: major Milestone: 0.21.1
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Summary

FTA channels cannot be locked on (l--). Encrypted channels have no problem (LAMC).

Kaffeine can play both types: encrypted and unencrypted channels.

Description

FTA channels cannot be tune (locked?) while I have no problem with encrypted channels. When using MythTV I see the following in the /var/log/messages

Dec 23 16:31:50 mythtvbackend tda1004x: setting up plls for 53MHz sampling clock
Dec 23 16:31:50 mythtvbackend tda1004x: found firmware revision 20 -- ok
Dec 23 16:31:53 mythtvbackend dvb_ca adapter 1: DVB CAM detected and initialised successfully

When using kaffeine and tuning in FTA I see only:

Dec 23 16:31:50 mythtvbackend tda1004x: setting up plls for 53MHz sampling clock
Dec 23 16:31:50 mythtvbackend tda1004x: found firmware revision 20 -- ok

while for encrypted channels I see:

Dec 23 16:31:50 mythtvbackend tda1004x: setting up plls for 53MHz sampling clock
Dec 23 16:31:50 mythtvbackend tda1004x: found firmware revision 20 -- ok
Dec 23 16:31:53 mythtvbackend dvb_ca adapter 1: DVB CAM detected and initialised successfully

Software

MythTV: 0.21_p19046

Kernel: 2.6.27-gentoo-r7 (SMP) i686 Intel(R) Pentium(R) 4 CPU 2.80GHz

Hardware:

  • Multimedia controller: Philips Semiconductors SAA7146 (rev 01)

Subsystem: Technotrend Systemtechnik GmbH DVB T-1500 Flags: bus master, medium devsel, latency 66, IRQ 18 Memory at f8520000 (32-bit, non-prefetchable) [size=512] Kernel driver in use: budget_ci dvb Kernel modules: budget-ci

  • CI from technotrend
  • CAM Connax 4.00

Attachments (1)

mythbackend.log.gz (171.3 KB) - added by Octavian Petre <octavsly@…> 10 years ago.
mythtvbackend log file

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Dibblah

Status: newinfoneeded_new

Can you attach logs of both good and bad tune attempts from mythbackend -v record,channel,dvbcam , please?

comment:2 Changed 10 years ago by Octavian Petre <octavsly@…>

Here is the log. Since in my system I also have a DVB-S (FTA), you might see some logs from there to.

The LiveTV procedure was :

channel '2'    (DVB-S: FTA)            :no issue

channel '204'  (DVB-T: encrypted)      :no issue!

channel '203'  (DVB-T: FTA thus NOT encrypted)  :ISSUE (no lock)
channel '202'  (DVB-T: FTA thus NOT encrypted)  :ISSUE (no lock)
channel '201'  (DVB-T: FTA thus NOT encrypted)  :ISSUE (no lock)
....

The only channels with the issue are 201,202,203 (DVB-T, FTA)

Changed 10 years ago by Octavian Petre <octavsly@…>

Attachment: mythbackend.log.gz added

mythtvbackend log file

comment:3 Changed 10 years ago by anonymous

Can you try the following and see if they individually make any difference:

In mythtv-setup, input connections, set "Use quick tuning" to never In mythtv-setup, capture cards, recording options, set "Max recordings" to 1, for all cards.

comment:4 Changed 10 years ago by Octavian Petre <octavsly@…>

Did all of that but no change.

Now I realize that it uses 474000000 frequency instead of 546000000.

In the channel editor I cannot see the frequency, so I could not see this mistake.

I have changed the "mplexid" for those 3 channels (from corresponding 474MHz to 546MHz) and now when I watchg LiveTV I get LMs (partial lock).

I was thinking to rescan that frequency again but unfortunately I cannot do that since mythtv-setup crashes in many different ways (segmentation fault, freeze, etc.) Do you have an idea on how to avoid this crash?

Best regards, Octavian

For your reference: Kaffeine shows:

Tuning to: Nederland 1 / autocount: 0
Using DVB device 1:0 "Philips TDA10046H DVB-T"
tuning DVB-T to 546000000 Hz
inv:2 bw:0 fecH:1 fecL:9 mod:3 tm:1 gi:3 hier:0
....... LOCKED.
NOUT: 1
dvbEvents 1:0 started
Tuning delay: 1110 ms

comment:5 in reply to:  4 Changed 10 years ago by sphery <mtdean@…>

Replying to Octavian Petre <octavsly@gmail.com>:

I was thinking to rescan that frequency again but unfortunately I cannot do that since mythtv-setup crashes in many different ways (segmentation fault, freeze, etc.) Do you have an idea on how to avoid this crash?

Pin the mythtv-setup process to a single core by starting mythtv-setup with "taskset -c 0 mythtv-setup" (no quotes).

comment:6 Changed 10 years ago by Octavian Petre <octavsly@…>

Thanks for that option. it helped a lot.

It did not crash anymore, but always gave me "no signal" when scanning on 546MHz... until I used "ignore signal timeouts" option. Then, it found the DVB-T FTA channels!!!!

However, when testing it in mythfrontend... surprise. It tries to lock on "DVBChan(6:1): 474000000 qam_64 a 1/2 1/2 8 8 1/4 n v"

And indeed, after scanning the 546MHz I get two new transponders, one on 474MHz and one on 714MHz...

I am now a bit lost...Any idea what is happening?

Best regards, Octavian

comment:7 Changed 10 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

comment:8 Changed 10 years ago by octavsly@…

The issue is still there. I can provide more information. Just let me know how.

Best regards, Octavian

comment:9 Changed 10 years ago by Octavian <octavsly@…>

This issues is fixed.

Useful attachments are present in #7102.

Note: See TracTickets for help on using tickets.