Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7102 closed defect (invalid)

Problem switching from encrypted channel to FTA channel

Reported by: einstein@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

hi,

there is an problem switching from an encrypted channel to an FTA channel. In the frontend-OSD it hangs on "LMs". When you switch to an other FTA channel then it changes to LMC and is working again.

Mythtv-Version is the latest source.

here is the backend log switching back from ecrypted ("LMSC") Channel back to the FTA channel hanging on "LMs":

2009-09-20 08:23:19.712 TVRec(19): HW Tuner: 19->19
2009-09-20 08:23:19.773 DVBChan(19:/dev/dvb/adapter2/frontend0) Warning: Your frequency setting (12544750) is out of range. (min/max:950000/2150000)
2009-09-20 08:23:19.988 Finished recording Teleshopping: channel 14012
2009-09-20 08:23:20.088 mythbackend version: trunk [21949] www.mythtv.org
2009-09-20 08:23:20.145 Using runtime prefix = /usr/local
2009-09-20 08:23:20.219 AutoExpire: CalcParams(): Max required Free Space: 4.0 GB w/freq: 15 min
2009-09-20 08:23:20.244 Using configuration directory = /etc/mythtv/.mythtv
2009-09-20 08:23:20.378 Empty LocalHostName.
2009-09-20 08:23:20.466 Using localhost value of MythTv
2009-09-20 08:23:20.526 New DB connection, total: 1
2009-09-20 08:23:20.552 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17504) desired(17501)
2009-09-20 08:23:20.579 Connected to database 'mythconverg' at host: localhost
2009-09-20 08:23:20.632 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17500) desired(17501)
2009-09-20 08:23:20.687 Closing DB connection named 'DBManager0'
2009-09-20 08:23:20.731 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17507) desired(17501)
2009-09-20 08:23:20.787 Connected to database 'mythconverg' at host: localhost
2009-09-20 08:23:20.892 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17505) desired(17501)
2009-09-20 08:23:20.901 Current Schema Version: 1244
2009-09-20 08:23:20.952 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17506) desired(17501)
2009-09-20 08:23:21.020 New DB connection, total: 2
2009-09-20 08:23:21.063 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17502) desired(17501)
2009-09-20 08:23:21.174 DTVSM(/dev/dvb/adapter2/frontend0) Error: Wrong PMT; pmt->pn(17503) desired(17501)
2009-09-20 08:23:21.119 Connected to database 'mythconverg' at host: localhost
2009-09-20 08:23:23.818 AFD: Opened codec 0x1ebb840, id(MPEG2VIDEO) type(Video)
2009-09-20 08:23:23.861 AFD: codec MP2 has 2 channels
2009-09-20 08:23:23.906 AFD: Opened codec 0x1ebc560, id(MP2) type(Audio)
2009-09-20 08:23:24.020 Preview: Grabbed preview '/speichergruppen/LiveTV/14012_20090920082309.mpg' 544x576@400s

Attachments (2)

mythtv_setup.scan (10.7 KB) - added by Octavian <octavsly@…> 10 years ago.
The console output when scanning the problematic FTA 546MHz frequency
mythbackend_tuning.log.gz (94.5 KB) - added by Octavian <octavsly@…> 10 years ago.
The mythbackend logfile (as requested) when tuning the problematic FTA 546MHz frequency

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by Janne Grunau

Status: newinfoneeded_new

please attach a -v record,channel,siparser backend log

comment:2 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

30 days without response.

comment:3 Changed 10 years ago by Octavian <octavsly@…>

First of all, I am sorry for re-opening this ticket.

In fact I think this is related to #6022.

Last Sunday I have updated to 0.22_p22824-r1 (gentoo version). The main reason for the upgrade was exactly this bug.

This issue is still present. Encrypted channels are OK while FTA cannot be locked on :-D.

I am willing to provide any information might be required to get this right.

Thank you for your time, Octavian

comment:4 Changed 10 years ago by Dibblah

So please provide the logs asked for above?

comment:5 Changed 10 years ago by Octavian <octavsly@…>

OK I will do this in the evening. I am not at home right now.

Is record,channel,siparser enough?

comment:6 Changed 10 years ago by Dibblah

Yes. Also, which hardware CAM and subscription card do you see this issue with?

comment:7 Changed 10 years ago by Octavian <octavsly@…>

CAM: CAM: Conax 4.00e, 01, 0B00, 04B1

SmartCard from Digitenne (NL) http://www.kpn.com/TelevisieNieuw.htm

mythbackend.log:

2009-11-16 09:35:47.859 CAM: Conax 4.00e, 01, 0B00, 04B1
2009-11-16 09:35:47.943 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.11026
2009-11-16 09:35:47.985 DVB#/dev/dvb/adapter1/frontend0 CA: CiHandler needs CA_PMT
2009-11-16 09:35:47.987 DVB#/dev/dvb/adapter1/frontend0 CA: Creating CA_PMT, ServiceID = 23
2009-11-16 09:35:47.988 Adding CA descriptor: CASID(0xb00), ECM PID(0x7f7)
2009-11-16 09:35:47.989 Adding elementary stream: video-mpeg2, pid(0x7ef)
2009-11-16 09:35:47.990 Adding elementary stream: audio-mp1-layer[1,2,3], pid(0x7f0)
2009-11-16 09:35:47.991 Adding elementary stream: private-data, pid(0x7f1)
2009-11-16 09:35:47.992 DVB#/dev/dvb/adapter1/frontend0 CA: Sending CA_PMT with CPLM_ONLY to CI slot #0
2009-11-16 09:35:48.101 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.1096
2009-11-16 09:35:48.254 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.11996
2009-11-16 09:35:48.407 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.13914
2009-11-16 09:35:48.564 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.1657
2009-11-16 09:35:48.717 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.13826
2009-11-16 09:35:48.870 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.11077
2009-11-16 09:35:49.024 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.08655
2009-11-16 09:35:49.178 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.06239
2009-11-16 09:35:49.331 DTVSM(/dev/dvb/adapter1/frontend0): Time Offset: -2.1008
2009-11-16 09:35:49.433 PID 0x7ef status: Decrypted

/var/log/messages

Nov 16 09:40:42 mythtvbackend saa7146: register extension 'budget_ci dvb'.
Nov 16 09:40:42 mythtvbackend budget_ci dvb 0000:05:09.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Nov 16 09:40:42 mythtvbackend IRQ 18/: IRQF_DISABLED is not guaranteed on shared IRQs
Nov 16 09:40:42 mythtvbackend saa7146: found saa7146 @ mem f8b22000 (revision 1, irq 18) (0x13c2,0x1012).
Nov 16 09:40:42 mythtvbackend saa7146 (0): dma buffer size 192512
Nov 16 09:40:42 mythtvbackend DVB: registering new adapter (TT-Budget-T-CI PCI)
Nov 16 09:40:42 mythtvbackend adapter has MAC addr = 00:d0:5c:07:da:69
Nov 16 09:40:42 mythtvbackend input: Budget-CI dvb ir receiver saa7146 (0) as /class/input/input3
Nov 16 09:40:42 mythtvbackend budget_ci: CI interface initialised
Nov 16 09:40:42 mythtvbackend DVB: registering adapter 1 frontend 0 (Philips TDA10046H DVB-T)...
...
Nov 16 09:40:42 mythtvbackend dvb_ca adapter 1: DVB CAM detected and initialised successfully

comment:8 Changed 10 years ago by Dibblah

Log from at least the start of tuning, if not from startup, please.

comment:9 Changed 10 years ago by Octavian <octavsly@…>

I will do that in the evening since I am not at home now and I cannot start mythfrontend in a NXMachine session.

The listing was posted to show the CAM type and the hardware I have used.

comment:10 Changed 10 years ago by Octavian <octavsly@…>

the issue is solved for me

Here are the steps I have followed.

  1. Rescanning of the FTA channels from mythtv-setup.

Initially the scan on the problematic frequency 546MHz did not work. As soon as the scanning of the transponder was started a timeout signal was given and no channels were found. All parameters were AUTO. The next step was to use kaffeine to tune in the 546MHz. This was successful. I have copied all parameters from kaffeine and pass them to mythtv. The result of the scan is attached in mythtv_setup.scan

  1. After starting the mythfrontend, the FTA channels were successfully tuned-in. For completeness I have attached mythbackend_tuning.log.gz.

Thanks Dibblah for spending some time on this, Octavian

Changed 10 years ago by Octavian <octavsly@…>

Attachment: mythtv_setup.scan added

The console output when scanning the problematic FTA 546MHz frequency

Changed 10 years ago by Octavian <octavsly@…>

Attachment: mythbackend_tuning.log.gz added

The mythbackend logfile (as requested) when tuning the problematic FTA 546MHz frequency

comment:11 Changed 10 years ago by Dibblah

Thanks for following up!

Note: See TracTickets for help on using tickets.