Opened 10 years ago

Closed 10 years ago

#7103 closed defect (duplicate)

Browsing to channels accross diseqc positions fails in 0.22 trunk

Reported by: hans@… Owned by: Janne Grunau
Priority: minor Milestone: 0.22
Component: MythTV - DVB Version: head
Severity: medium Keywords: diseqc tune channel
Cc: Ticket locked: no

Description

When I used to browse through the channel list with 0.21-fixes and pressed 'OK', the channel would be tuned. This was across diseqc position or on the same diseqc position.

Now, when I press 'OK' on a channel which is on a different diseqc position, the channel tune will fail and I will be thrown back to the first channel on the default diseqc position (Channel 1). Changing channels in this way work when the channel is on the same diseqc position.

When I press the channel number and change channels in this way, the channel change does work. Also, changing the input to the other diseqc position first works as well.

Being able to scroll through the channels with the up/down keys and changing the channels is very important to the Wife Appreciation Factor.

Hans

Change History (5)

comment:1 Changed 10 years ago by sphery

dup of #6208 ?

comment:2 Changed 10 years ago by sphery

and/or dup of #7197

comment:3 Changed 10 years ago by anonymous

There are some similar symptoms, some things which appear to be different. I keep being able to browse the channels, but always the channel change only works by pressing OK or Enter if the channel is on the same diseqc.

Changing the channel by typing the channel number always works, as does the history button for channels on different disqec. I'm on trunk 2226X now. Please advice on what logs need to be provided and on how to obtain those.

The issue is rather annoying in an increasingly stable system.

Hans

comment:4 Changed 10 years ago by anonymous

It does seem to be a dup of 7197. I cannot test the patch however, because I do not build my own MythTV. I use the PPA builds from Ubuntu. What can I do to confirm my issue or help in getting this fixed?

Hans

comment:5 Changed 10 years ago by sphery

Resolution: duplicate
Status: newclosed

Dup of #7197. If you still see the issue after #7197 (and #6208) is(are) fixed, please let us know. Thanks for the quick response.

Note: See TracTickets for help on using tickets.