Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6132 closed defect (invalid)

mythbackend stuck at 100% cpu during ATSC recording

Reported by: karlcz@… Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: mythtv Version: 0.21-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

At random times, mythbackend gets stuck during ATSC recordings, spinning at 100% cpu rather than crashing, and it seems clustered on some evenings like maybe it has to do with interference or corruption in the broadcast. This is in an urban area with an amplified indoor antenna and lots of chances for signal problems. I have to do a mythbackend restart to get it cleared. I am using a Hauppauge WinTV-HVR1800 card. It happens many times per week and disrupts recordings or live TV watching.

I don't know what kind of information I can provide to help. I am using the pre-compiled mythtv-0.21-15.fc10.x86_64 packages from rpmfusion. I suspect this problem started after upgrading from the previous -14 package, though I am not certain. This is the interval between release-0-21-fixes (r19344) and release-0-21-fixes (r19169) according to the RPM changelog.

Attachments (4)

mythbackend-backtrace-1.txt (14.7 KB) - added by anonymous 11 years ago.
mythbackend-backtrace-2.txt (14.7 KB) - added by anonymous 11 years ago.
mythbackend-backtrace-3.txt (14.7 KB) - added by anonymous 11 years ago.
mythbackend-backtrace-4.txt (14.8 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by danielk

Priority: majortrivial
Severity: mediumlow
Status: newinfoneeded_new

We need at least a backtrace taken when the CPU is at 100%, and we may need a profiling trace if that is not sufficient.

comment:2 Changed 11 years ago by paulh

Status: infoneeded_newnew

r19344 has the infinite loop bug in it introduced in r19342 which was fixed in r19358. So you need to update to r19358 or later.

comment:3 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

if paul is correct about the cause this was fixed in head at the time of reporting.

comment:4 Changed 11 years ago by anonymous

The problem persists with rpmfusion's test update 0.21-16 which claims to be up to r19505. I will attach some thread backtraces taken several times from the same spinning process (attaching and detaching with gdb so you can see if they are always in the same routines or not... I don't know the code so don't really know what the stacks are telling me).

Changed 11 years ago by anonymous

Attachment: mythbackend-backtrace-1.txt added

Changed 11 years ago by anonymous

Attachment: mythbackend-backtrace-2.txt added

Changed 11 years ago by anonymous

Attachment: mythbackend-backtrace-3.txt added

Changed 11 years ago by anonymous

Attachment: mythbackend-backtrace-4.txt added
Note: See TracTickets for help on using tickets.