Opened 11 years ago

Closed 10 years ago

#6148 closed defect (duplicate)

MythTV Internal player finishes 4 seconds too early on AVIs?

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords: internal player avi
Cc: Ticket locked: no

Description

I am using MythTV 0.21 fixes build 19693

When playing back AVI files the internal player cuts approximately 4 seconds off the end.

If the On Screen Display is visible at the time it displays 00:00:04 and then stops and shows the Save It / Delete It menu selection.

As reported in the ticket below but the ticket says open another ticket.

http://svn.mythtv.org/trac/ticket/4359

Change History (4)

comment:1 Changed 11 years ago by anonymous

Do not know if I should report in a separate ticket (or perhaps the title could be updated - just remove "on AVIs") but this problem also affects MPG recordings also from a DVB-T USB stick.

Approximately 4 seconds is cut off the end and the On Screen Display stops at 00:00:04 and does not display 00:00:03, 00:00:02 etc seconds.

comment:2 Changed 10 years ago by anonymous

If I switch off "Prompt At End Of Recording" (see ticket http://svn.mythtv.org/trac/ticket/6448) the internal player still cuts approximately 3 seconds off the end (not 4 seconds) on all recordings both AVI and MPG. For short recordings/clips and if you have cut especially close to the end of programmes you frequency missed important part of the programme - it is amazing how significant the last 3/4 seconds can be.

comment:3 Changed 10 years ago by anonymous

Also refer to http://svn.mythtv.org/trac/ticket/6974 which may fix this problem when the patch is applied.

comment:4 Changed 10 years ago by sphery

Resolution: duplicate
Status: newclosed

Duplicate of #6974.

The 2-second end-of-recording margin can not be decreased without changes to the player. I've attached a patch to #6974 that reduces the margin to 1/3 second, but it can only be used with the other patch on #6974, so this issue will be fixed along with #6974.

Note: See TracTickets for help on using tickets.