Opened 11 years ago

Closed 11 years ago

#6378 closed defect (fixed)

LiveTV Pauses when entering EPG

Reported by: Zach C <uid000@…> Owned by: Shane Shrybman
Priority: minor Milestone: 0.22
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

#6062 is still a problem for me in r20230. Is there something I'm missing or should configure?

Sorry for the delay in reporting. Just back to MythTV after a hiatus.

Attachments (1)

mythfrontend.log (21.4 KB) - added by Zach C <uid000@…> 11 years ago.
mythfrontend log with -v playback

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Shane Shrybman

Component: MythTV - GeneralMythTV - Video Playback
Milestone: unknown0.22
Owner: changed from Isaac Richards to Shane Shrybman
Status: newaccepted

No, nothing should need to be configured.

Another frontend log like the one provided on #6062 might provide some clues.

comment:2 Changed 11 years ago by Zach C <uid000@…>

I'll try to post a log from the frontend today. What log options would be useful?

comment:3 Changed 11 years ago by Shane Shrybman

Status: acceptedinfoneeded

The same options used on the log file for #6062.

Changed 11 years ago by Zach C <uid000@…>

Attachment: mythfrontend.log added

mythfrontend log with -v playback

comment:4 Changed 11 years ago by Zach C <uid000@…>

I just added the log output from the frontend. At 17:30:16.801 we see DoPause?() -- begin This is when I entered the EPG from LiveTV

At 17:30:19.879 we see DoPlay? -- begin This is where I hit "escape" to return to LiveTV

Additional info:

mythfrontend --version

MythTV Version : 20232 MythTV Branch : trunk Library API : 0.22.20090312-1 Network Protocol : 44 QT Version : 4.4.3 Options compiled in:

linux release using_oss using_alsa using_arts using_backend using_directfb using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

mythbackend --version

MythTV Version : 20232 MythTV Branch : trunk Library API : 0.22.20090312-1 Network Protocol : 44 QT Version : 4.4.3 Options compiled in:

linux release using_oss using_alsa using_arts using_backend using_directfb using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

comment:5 Changed 11 years ago by Shane Shrybman

Hmm, I can't reproduce the problem here but I don't have vdpau.

Does the problem happen every time you enter the guide? How about when not using vdpau?

comment:6 Changed 11 years ago by Zach C <uid000@…>

Yes, just tested with the CPU-- profile (video 1280x720, h.264) and other than being generally unusable due to stuttering video, the EPG works properly. TV keeps playing in a thumbnail in the guide (there was no thumbnail with VDPAU).

comment:7 Changed 11 years ago by Zach C <uid000@…>

I just updated my Nvidia drivers to 180.29 to see if it made a difference, since the problem seems to be related to VDPAU in some way. Unfortunately, this didn't help.

comment:8 Changed 11 years ago by markk

Resolution: fixed
Status: infoneededclosed

(In [20291]) Don't pause Live TV if no preview window is available in the EPG. Closes #6378.

Note: See TracTickets for help on using tickets.