Opened 11 years ago

Closed 11 years ago

#6421 closed patch (fixed)

Pseudo-hashes are deprecated at ./tmdb.pl line 268.

Reported by: Marc Tousignant <drayson@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: head
Severity: medium Keywords: tmdb.pl Pseudo-hashes deprecated concatenation
Cc: Ticket locked: no

Description

I am running an issue with the tmdb.pl from this ticket. All my other movie backdrop downloads work fine with the exception of Dead Like Me: Life After Death. Examples: This one works fine. “Babylon A.D.” # ./tmdb.pl -M "Babylon A.D." 0364970:Babylon A.D. (2008)

# ./tmdb.pl -B 0364970 http://www.themoviedb.org/image/backdrops/3314/tt0364970-2.jpg http://www.themoviedb.org/image/backdrops/5402/tt0364970.jpg http://www.themoviedb.org/image/backdrops/18590/Babylon_AD.jpg

This one does not. (Dead Like Me: Life After Death) # ./tmdb.pl -M "Dead Like Me: Life After Death" 1079444:Dead Like Me: Life After Death (2009) 1079444:Dead like Me-Life After Death

# ./tmdb.pl -B 1079444 Pseudo-hashes are deprecated at ./tmdb.pl line 268. Use of uninitialized value in concatenation (.) or string at ./tmdb.pl line 87. Can't use string ("You need to search for something") as a HASH ref while "strict refs" in use at ./tmdb.pl line 275.

Attachments (4)

tmdb.fix.diff (628 bytes) - added by robert.mcnamara@… 11 years ago.
Fix.
tmdb.pl.patch (725 bytes) - added by Michelle Agnew <mythtrac@…> 11 years ago.
Fix array detection after the data structure is parsed from the XML
tmdb.pl_v3.patch (1.3 KB) - added by Michelle Agnew <mythtvtrac@…> 11 years ago.
tmdb.pl_v4.patch (1.6 KB) - added by Michelle Agnew <mythtvtrac@…> 11 years ago.

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by robert.mcnamara@…

Attachment: tmdb.fix.diff added

Fix.

comment:1 Changed 11 years ago by robert.mcnamara@…

Fix enclosed. I'm not a Perl hacker, I just play one on TV.

comment:2 Changed 11 years ago by Marc Tousignant <drayson@…>

patched and confirmed on my system. Thanks

comment:3 Changed 11 years ago by Rob Smith

Component: MythTV - GeneralPlugin - MythVideo
Owner: changed from Isaac Richards to Anduin Withers
Type: defectpatch
Version: unknownhead

comment:4 Changed 11 years ago by robert.mcnamara@…

This isn't a total solution, as this change fixes one but breaks another (Pinocchio) ("Not an array reference"). Should be obvious to someone who actually knows perl. :)

Changed 11 years ago by Michelle Agnew <mythtrac@…>

Attachment: tmdb.pl.patch added

Fix array detection after the data structure is parsed from the XML

comment:5 Changed 11 years ago by robert.mcnamara@…

Tested and confirmed against all ticket examples here. Thanks, Michelle.

comment:6 Changed 11 years ago by drayson@…

Confirmed. Works for me too.

Changed 11 years ago by Michelle Agnew <mythtvtrac@…>

Attachment: tmdb.pl_v3.patch added

comment:7 Changed 11 years ago by Michelle Agnew <mythtvtrac@…>

Michael T Dean reported a new issue: Not an ARRAY reference at ./tmdb.pl line 182 (happens with ./tmdb.pl -D 1126596)

I've fixed tmdb.pl for the above issue use: tmdb.pl_v3.patch

There are more places where this could happen in the code and I will look into them and fully patch the code. Expect an update in the next few days.

Michelle

Changed 11 years ago by Michelle Agnew <mythtvtrac@…>

Attachment: tmdb.pl_v4.patch added

comment:8 Changed 11 years ago by Michelle Agnew <mythtvtrac@…>

I've gone through the code and updated the problem areas with a cleaner fix and checked for any other areas that may have had the same issue. I think I've caught them all and I tested by running through all of the examples in this ticket and they are all working fine.

Use the new patch tmdb.pl_v4.patch

Michelle

comment:9 Changed 11 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [20606]) Fixes #6421 with a patch by MeShe?. Thanks!

Note: See TracTickets for help on using tickets.