Opened 11 years ago

Closed 10 years ago

#6456 closed defect (duplicate)

DVD Playback stutters

Reported by: alan@… Owned by: skamithi
Priority: major Milestone: unknown
Component: MythTV - DVD Playback Version: 0.21-fixes
Severity: high Keywords: DVD playback stutter jump
Cc: Ticket locked: no

Description

Nearly all DVDs stutter when played with the internal player, and it is especially bad with Animusic 2. The same DVDs play perfectly with Xine. Also, ripping the DVD to an ISO and playing using the internal player in MythVideo? (across NFS) works perfectly.

Disabling Monitor DVD/CD improves the situation, but does not solve it.

Disabling deinterlacing etc. makes no difference.

The most common error message during the stuttering is

Video is XXXXXX frames behind audio (too slow), dropping frame to catch up.

Increasing the playback speed to 1.1x or reducing to 0.9x eliminate the stutter completely.

My DVD drive is a SATA drive, but switching to an IDE drive makes no difference (DMA is shown as enabled in both cases)

I have had the problem for a long time (since 0.21, but not in 0.20-X), but have not had chance to eliminate all issues until recently.

Attached is an old log file, captured while trying to debug this issue.

I am running Ubuntu 8.04.1 and Mythbuntu weekly builds of 0.21-fixes (currently 20324).

Thanks

Alan

Attachments (1)

dvd.normal.log.gz (21.5 KB) - added by alan@… 11 years ago.
dvd log file during stuttering

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by alan@…

Attachment: dvd.normal.log.gz added

dvd log file during stuttering

comment:1 Changed 11 years ago by anonymous

Do you have libdvdcss2 installed? if not, what happens if you install it?

I know it sounds unlikely but this seems to have just fixed most of my dvd playback stuttering in trunk.

Failing that, can you describe your audio setup and give any hint whether it is specific audio stream types that generate the issue (i.e. plain old stereo fine, 6/7 channel audio broken).

comment:2 Changed 11 years ago by alan@…

yes libdvdcss2 1.2.9 from Medibuntu is installed.

Audio wise, I am using ALSA:Default, myth controlling volume levels via /dev/mixer, stereo only via the 3.5 mm connector on the back of the PC to an external amp. Disabling audio completely, audio device /dev/null, does not fix the problem. Everything works with the internal player fine except actual DVD playback, some DVDs worse than others - ripped ISOs of the DVDs with problems work perfectly, the DVDs themselves work perfectly with Xine.

I don't know what is different between normal playback and when speed is increased to 1.1x, but in my system, sound and video are perfect at 0.9x and 1.1x (albeit too slow or fast) - which would eliminate most configuration issues as well hardware limitations.

Everything, so far, points to an issue in MythVideo?.

comment:3 Changed 11 years ago by alan@…

In response to Mike Dean - apologies for my error, please leave as bug request for now. The issue existed long before I enabled internal volume controls.

They are (and were) both ALSA:default (selected from drop down menu - so capitalization as defined in Myth). Settings are (paraphrased) Audio device ALSA:default Passthrough Default Audio channels stereo Upmix passive Use internal controls Mixer device ALSA:default Mixer PCM

Thanks

Alan

comment:4 Changed 10 years ago by stuartm

Status: newinfoneeded_new

Have you tried increasing the disc rotation speed to the maximum (12x)?

Can you reproduce with trunk?

comment:5 Changed 10 years ago by alan@…

I previously played with the DVD drive speed, and it was left at 12x - it has made no discernible difference.

I will get the Mythbuntu Trunk version of pre-built binaries, is this adequate?

My backend, for WAF reasons cannot be easily upgraded and is the current Mythbuntu 0.21-fixes as well, can the trunk work with this?

Thanks

Alan

comment:6 Changed 10 years ago by anonymous

No, all backends and frontends must be the same version.

comment:7 Changed 10 years ago by alan@…

After a little wrestling I was able to get 0.21+trunk20931 (from Mythbuntu repositories), running - I created a local master backend, so eliminating all the old settings. Animusic 2, the DVD I use for testing, seg faults as soon as it exits the main menu and tries to play the actual DVD, i.e. press play, watch the outro, and as soon as it switches to the first "scene", mythfrontend exits and seg faults. The menu stuttered as badly as it does with 0.21+fixes. And as with 0.21 fixes, it plays smoothly second time around on every frame shown previously, and then stutters again on new frames - as if the data is held in a buffer. Playing another disc, then re-inserting Animusic gets back to the stuttering. For clarity, when I say stuttering, I mean the image jumps as if skipping a number of frames or pausing between frames, the audio is fine. I was unable to jump to a scene from the main menu either - again as soon as a scene is supposed to play, Myth seg faults.

I tried Gladiator - and while that played, it too stuttered - nowhere near as bad as Animusic, but then it never was as bad previously either.

I also tried Wall-E, the menus still don't work properly there - once I select play, it gets stuck looping between the FBI warnings and a disclaimer (which whips passed to fast for me to read). Selecting scene selection and choosing the first scene starts it up OK. However there is still stuttering on this DVD as well.

I tested all three DVDs with Xine and Totem (Gstreamer), both handled the menus and play back fine - Totem had a few issues with Wall-E's menu, but more being very slow, rather than not functioning. There was no stuttering or playback issues with either.

It seems to be a bandwidth issue, as Animusic reputedly uses every available mbps of the DVD format, and on other DVDs, while major scene changes are often handled well, panning and lots of action seem to trigger the stuttering behavior as well.

Any ideas - anything else to check?

Thanks for the support - I appreciate it. I've been using MythTV since 0.11 (I think - Sept 03 at least), and each step forward is well worth it - I'd really like to nail this problem, because when it works the DVD playback is great.

comment:8 Changed 10 years ago by chris@…

I have been having a similar if not the same problem as the original poster. DVD playback with the internal player results in occasional stuttering of the video. Ripping to ISO and playing back with the internal player works. Playback with mplayer works. I have tried various decoder settings, disabling the DVD monitor, changing disc rotation speed, disabling interlacing, changing OSD settings without any success.

I am running Mythbuntu with Mythtv 0.21. I also have a SATA DVD drive. This has been a problem for at least a year. DVD playback is watchable since the audio is not affected, but I find it distracting.

I have no reported errors in mythfrontend.log when the stuttering occurs.

I would be ecstatic to solve this problem. Let me know what details of my setup I can provide.

comment:9 Changed 10 years ago by stuartm

Resolution: duplicate
Status: infoneeded_newclosed

Duplicate of #6367. Would someone please test the patch on #6367 and reply there?

Note: See TracTickets for help on using tickets.