Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 5 years ago

Closed 4 years ago

#6581 closed patch (duplicate)

Audio Delay / Lipsync Control

Reported by: anonymous Owned by: ijr
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords: lipsync audio sync
Cc: Ticket locked: yes

Description

From the wiki:

The current audio delay in the frontend allows for temporary adjustment to align the audio with the video. Unfortunately, many HDTV owners experience a problem where the audio is about 30-40ms ahead of the video due to the 30-40ms delay that modern HDTV video processors create. While the temporary audio delay controls already implemented in the Myth frontend can help, it would be beneficial to allow a permanent baseline audio delay to be set amongst all recordings. That way, by default the audio could be delayed by 30-40ms, which will align it for most programs, allowing minor adjustment via the temporary audio delay to not always be necessary.

Having the same issue, I added a, IMHO, nice feature which enables the user to set up a audio sync offset in the general settings of mythfrontend (separate for each host). This offset is added initially to the audio offset already used transiently during playback. The user may also set a special additional delay during a show like before; the global setting is displayed in brackets.

I attached the patch which can be used against the trunk, revision 20635.

I am really looking forward for your opinions!

Attachments (1)

lipsync_patch.txt (4.5 KB) - added by andreas.dey 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by andreas.dey

comment:1 Changed 5 years ago by el_duderino

Sorry, forgot my name: it's Andreas, not Mr. anonymous ;-)

comment:2 Changed 5 years ago by anonymous

I've also have the same issue on my LCD tv. All recordings have an offset which isn't present when I'm playing on my other TV.

Will this patch be accepted into the MythTV trunk any time soon?

comment:3 Changed 4 years ago by HyRax

Having this feature would be really good for Sony Bravia TV's that have motion-processing features like "MotionFlow?". Other TV's are now getting similar features and rather than have to manually setup 200ms of audio delay each time I watch something to ensure the sync is right, it would be so much better to have a global settings that applied to all audio played.

I'm using MythTV 0.23 Trunk, so would it be difficult to commit the patch that Andreas proposed?

comment:4 Changed 4 years ago by stuartm

  • Ticket locked set

Discussion belongs in the mailing list, NOT trac.

comment:5 Changed 4 years ago by robertm

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #6581, #4262 (I will cross-reference all on the original ticket)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.