Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#4262 closed patch (Fixed)

Save audio sync adjustment per channel

Reported by: Mark Buechler <Mark.Buechler@…> Owned by: jyavenard
Priority: minor Milestone: 0.24
Component: MythTV - Audio Output Version: head
Severity: low Keywords:
Cc: Ticket locked: yes

Description

This patch allows the user to save the current audio sync adjustment for the watched channel. This presents a submenu to "Adjust Audio Sync" to "Save Adjustment". However, clicking "Adjust Audio Sync" has the same behavior as before.

Attachments (4)

myth_saveaudiosync_r14915.diff (5.0 KB) - added by Mark Buechler <Mark.Buechler@…> 6 years ago.
The patch. This requires an additional column to mythconverg.channel, patch for dbcheck included.
myth_saveaudiosync_r14915_v2.diff (7.4 KB) - added by Mark Buechler <Mark.Buechler@…> 6 years ago.
Better patch
myth_saveaudiosync_r14915_v3.diff (7.8 KB) - added by Mark Buechler <Mark.Buechler@…> 6 years ago.
Forgot to initialize audiosyncSaved and set it on SaveAudiosyncToDb?().
myth_saveaudiosync_r14915_v4.diff (8.1 KB) - added by Mark Buechler <Mark.Buechler@…> 6 years ago.
Forgot case for watch recording and saving audio sync

Download all attachments as: .zip

Change History (19)

Changed 6 years ago by Mark Buechler <Mark.Buechler@…>

The patch. This requires an additional column to mythconverg.channel, patch for dbcheck included.

comment:1 Changed 6 years ago by Mark Buechler <Mark.Buechler@…>

Looks like the audio sync adjustment isn't getting properly set in all cases. I'll submit a second patch fixing this.

comment:2 Changed 6 years ago by Robin Gilks <g8ecj@…>

I get several channels from 2 sources - DVB-S and an STB via IVTV s-video input. The DVB-S channels are OK but the IVTV channels require a 260mS adjustment on all of them so I'm not sure if per channel is correct, maybe the patch should look at per video source (or whatever its called this week) instead.

I also see a difference per frontend as well so maybe it needs to be indexed per host.

Good idea to save it though :-)

Changed 6 years ago by Mark Buechler <Mark.Buechler@…>

Better patch

comment:3 Changed 6 years ago by Mark Buechler <Mark.Buechler@…>

Created second patch. This one properly sets audio sync when changing channels by direction, by channum and by switching inputs. Also, modified the Audio Sync dialog to show the saved value.

Changed 6 years ago by Mark Buechler <Mark.Buechler@…>

Forgot to initialize audiosyncSaved and set it on SaveAudiosyncToDb?().

Changed 6 years ago by Mark Buechler <Mark.Buechler@…>

Forgot case for watch recording and saving audio sync

comment:4 Changed 5 years ago by Dibblah

Mark, is there a possibility of you enhancing this with a 'global' per front end default in the settings table? Changing the "Save sync" so it can also save this global value would be good.

comment:5 Changed 5 years ago by stuartm

  • Component changed from mythtv to MythTV - Video Playback

comment:6 Changed 4 years ago by robertm

See #6581, #4262 for alternate approaches.

comment:7 Changed 4 years ago by robertm

See also #7772.

comment:8 Changed 4 years ago by Andreas Fey

A general control over all playback media would be great (as in #6581), because when using a Flat TV as a display I have an exact delay of 200ms everytime; setting this delay thousand times for all channels might get boring...

comment:9 Changed 4 years ago by danielk

  • Component changed from MythTV - Video Playback to MythTV - Audio Output
  • Owner changed from ijr to jyavenard
  • Status changed from new to assigned

comment:10 Changed 4 years ago by natuk

Identical problem here between two frontends, one syncing by default, the other one always about 500ms off. So a per frontend setting would make sense.

comment:11 Changed 4 years ago by robertm

  • Ticket locked set

comment:12 Changed 3 years ago by markk

  • Resolution set to Fixed
  • Status changed from assigned to closed
  • Ticket locked unset

The offset is now persistent for each frontend following r27148. There are no plans to add a per-channel offset.

comment:13 Changed 3 years ago by Tianon Gravi <admwiggin@…>

What about per-input source? All my videos in MythVideo? play perfectly, but the ones I have recorded play best with a 370ms offset (the weirdest part is that the exact same recording file plays perfectly synced in VLC outside of MythTV, but that's a different topic).

comment:14 Changed 3 years ago by mdean

  • Ticket locked set

Per-input source, like per-channel and per-CODEC, offsets would be applied across all frontends--regardless of how they were connected to audio output (digital connection to receiver, digital connection to TV, analog connection to speakers, ...), so it would likely make things better on one frontend and worse on another. We are not going to make per-input, per-channel, per-CODEC offset settings for each host.

The current approach provides a good compromise that allows each system to be adjusted for equipment delays (such as differences in delay within a TV and an audio receiver each receiving direct input from the MythTV box). If the issue is caused by differences in audio delay within processing equipment based on the CODEC used, you'll need to either adjust for that delay in the equipment (i.e. pass audio and video through an A/V receiver and set it to account for the various delays) or use TOGGLEAUDIOSYNC (or the MENU) to bring up the "Adjust Audio Sync" control and make adjustments when necessary. If the issue is caused by broken encoding by the broadcaster/re-broadcaster (that truly affects all shows on a given channel or input), you should contact your broadcaster/re-broadcaster to get them to fix the problem rather than attempt to work around it.

comment:15 Changed 3 years ago by beirdo

  • Milestone changed from unknown to 0.24

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.