Opened 10 years ago

Closed 10 years ago

#6598 closed defect (worksforme)

VDPAU subpicture scaled incorrectly

Reported by: tim@… Owned by: markk
Priority: minor Milestone: 0.22
Component: MythTV - DVD Playback Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Head revision 20658

When playing a 4:3 ratio DVD (or .mkv with DVD subpicture subtitles) on a 16:9 ratio TV using VDPAU, the picture is displayed correctly, but the subtitles appear scaled to the full width of the 16:9 screen. This can be readily seen with wider subtitle text where it overlaps the edge of the picture.

This is not normally a problem for soundtrack subtitles (hence the low severity), where the text is merely a little ugly. It can however cause irritation when the subpicture has been used to position translations for in-picture text (e.g. Japanese/Chinese? characters on signs), as these then appear in the wrong place and obscuring things they were not intended to obscure.

The problem does not seem to affect normal Xv (non-VDPAU) rendering where the subtitles are scaled correctly.

Change History (4)

comment:1 Changed 10 years ago by markk

Milestone: unknown0.22
Owner: changed from skamithi to markk
Status: newassigned

comment:2 Changed 10 years ago by tim@…

I wonder what words I can remove to avoid this being flagged as spam...

I've just tried this with a couple more DVDs and it seems fine, but when I make a mkv out of a title on one it still shows the problem, so maybe it's just mkv files or similar

The DVD I originally saw the problem with is lent out to someone so I can't check that one right now.

comment:3 Changed 10 years ago by markk

Status: assignedaccepted

comment:4 Changed 10 years ago by markk

Resolution: worksforme
Status: acceptedclosed

I've tested VDPAU playback with a pretty wide selection of DVDs over the last few weeks and months (with different systems and displays) and cannot reproduce this issue. I can't comment on mkv files.

If there is still a problem, please raise again.

Note: See TracTickets for help on using tickets.