Opened 10 years ago

Closed 10 years ago

#6599 closed defect (invalid)

m4a files cause myth music lock-up

Reported by: markdavidoff@… Owned by: stuartm
Priority: minor Milestone: 0.22
Component: Plugin - MythMusic Version: 0.21
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I was importing music files using mythmusic, and it kept locking-up when it came to updating the database

I opened mythtv in verbose mode, and found that it was locking up on m4a files while trying to read the metadata.

I can attach the music file if the developers need it for debugging

Attachments (1)

gdb.txt (14.0 KB) - added by markdavidoff@… 10 years ago.
Backtrace

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by stuartm

Milestone: unknown0.22
Status: newinfoneeded_new

I can't reproduce with trunk.

A backtrace would initially be more useful than the file - http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Changed 10 years ago by markdavidoff@…

Attachment: gdb.txt added

Backtrace

comment:2 Changed 10 years ago by markdavidoff@…

One of the files is attached here. http://www.sendspace.com/file/1s5ei5

and I generated a backtrace with gdb (thanks for the link) which I attached

comment:3 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

Ok I can reproduce the problem, I just don't see an easy solution without disabling tag reading for m4a/aac. It's not a MythTV bug, it gets stuck in the mp4ff metadata library.

As a workaround you might uncheck the tag scanning option in the mythmusic settings. This will fall back to establishing artist/album/track metadata from the file path.

For trunk I'm looking at the forthcoming mp4 support in taglib, a 1.6 release isn't far away but we may also opt to keep our own copy of the library.

Note: See TracTickets for help on using tickets.