Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6814 closed enhancement (fixed)

Contextualise 'Watch Recordings' menu & add ability to set/unset 'watched' flag on playlist items

Reported by: Justin Hornsby Owned by: paulh
Priority: minor Milestone: 0.23
Component: MythTV - General Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

The attached patch changes the 'watch recordings' menu functionality so that only one button is required instead of two buttons currently used.

When the group list is selected and MENU is pressed, the group list menu popup is shown.

If the recordings list is selected when MENU is pressed, the 'recording options' menu is shown.

Both the group list menu & the recording options menus can be reached from one another.

When either the group list or recording list are selected, pressing INFO now shows the program details screen. This replaces the current DETAILS button.

I've also added the ability to mark/unmark items in the playlist as watched

Attachments (5)

pbbmenuchange2.diff (4.4 KB) - added by Justin Hornsby 10 years ago.
pbbmenucontextualise.diff (4.3 KB) - added by Justin Hornsby 10 years ago.
New patch with lines removed rather than commented out
patch-6814mine.cpp (4.4 KB) - added by ylee@… 10 years ago.
Revised patch against 0.22-fixes
6814-v1.diff (9.9 KB) - added by paulh 10 years ago.
Updated patch to current trunk
6814-v2.diff (9.9 KB) - added by paulh 10 years ago.
Fixed a bug with menu not always toggling properly

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Justin Hornsby

Attachment: pbbmenuchange2.diff added

Changed 10 years ago by Justin Hornsby

Attachment: pbbmenucontextualise.diff added

New patch with lines removed rather than commented out

comment:1 Changed 10 years ago by paulh

Milestone: 0.220.23

This is not a bug so pushing to 0.23

Changed 10 years ago by ylee@…

Attachment: patch-6814mine.cpp added

Revised patch against 0.22-fixes

comment:2 Changed 10 years ago by ylee@…

Attached is a revision of the patch (against 0.22-fixes) with two changes to justinh's work:

  • Eliminate the redundant "Recording Options Menu" button when focus is on the group list.
  • When the button is there put "Help (Status Icons)" above it and not below, so users can always go up from the default starting location to get to the button for the other menu.

comment:3 Changed 10 years ago by paulh

(In [23064]) Separate out the part of Justin's patch on ticket #6814 which allows all the items in a playlist to be marked as watched/unwatched. Slightly modified to allow it to work with current trunk. Refs #6814.

Changed 10 years ago by paulh

Attachment: 6814-v1.diff added

Updated patch to current trunk

comment:4 Changed 10 years ago by paulh

Updated the patch to apply to current trunk. Also updated it to toggle the menu shown when MENU is pressed and show the details page when INFO is pressed.

Changed 10 years ago by paulh

Attachment: 6814-v2.diff added

Fixed a bug with menu not always toggling properly

comment:5 Changed 10 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:6 Changed 10 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [23103]) Contextualise 'Watch Recordings' menu.

Only MENU is now required to show both the group and recording list menus. Which one is shown depends on which list has the focus. Pressing menu repeatably will alternate between the menus.

INFO is now used to display the program details.

Original patch by justinh. Closes #6814.

comment:7 Changed 10 years ago by sphery

(In [23106]) Fix keybinding usage consistency issues and keybinding collision between Global EDIT keybinding and TV Frontend CustomEdit? keybinding and update keys.txt and the HOWTO.

Removes the default binding for CUSTOMEDIT (which is only used in TV Frontend context). The DB update removes the CUSTOMEDIT keylist if it is the default ('E'). Users wanting to access the Custom Rule editor through the key binding rather than using the MENU may need to map a key, unless they have already changed the default binding.

In guidegrid and viewscheduled, changes INFO to show details() (like DETAILS) rather than performing editSchedule()/edit(). EDIT still does editSchedule()/edit().

In programrecpriority, changes INFO to show details() (like DETAILS) rather than edit(). Now, EDIT performs edit() (like SELECT).

In playbackbox, adds Custom Edit functionality to the MENU|Recording Options menu (for those who do not map CUSTOMEDIT). Custom Edit is already available through the menu in all other locations it's used (guidegrid.cpp, viewscheduled.cpp, progfind.cpp, proglist.cpp, and programrecpriority.cpp).

These changes help to prepare Myth for the eventual merging of INFO and DETAILS. After [23103] and this change, the only remaining area where DETAILS is used and differs from INFO is proglist.cpp, where INFO is being used to pop up an "alternatate" menu, different from that shown by MENU (similar to what was done in playbackbox.cpp before [23103]).

Also updates the HOWTO and keys.txt for these changes and the changes in [23103]. Refs #6814.

Note: See TracTickets for help on using tickets.