Opened 10 years ago

Closed 9 years ago

#6815 closed defect (wontfix)

Keyboard focus broken with Qt based UI widgets

Reported by: pik Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Mythtv-setup Version: head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

The problem can be reproduced by deleting all capturecards in mythtv-setup and then redefining them. It is then impossible to define the disecq settings after the capturecards have been deleted. It can also be reproduced by creating a fresh mythconverg database from scratch.

The workarround that I found was to manually enter the disecq ID in the capturecard table ( it is 0 by default instead of 1 ). I also needed to create an entry in the disecq_tree table ( fields updated : disecqid=1, disecqports=2, disecqordinal=1)

Change History (10)

comment:1 Changed 10 years ago by pik

tested with svn 21269 and kernel 2.6.30

comment:2 Changed 10 years ago by stuartm

Known bug, you have to press Down before you can bring up the Diseqc menu to select LNB etc

I may just get around to porting those screens to mythui which would solve the problem, or someone will have to figure out the focus issues following the QT4 port.

comment:3 Changed 10 years ago by stuartm

Version: head

comment:4 Changed 10 years ago by danielk

Summary: Configuring disecq settings in Mythtv-setup does not work in svn21123Keyboard focus broken with Qt based UI widgets

comment:5 Changed 10 years ago by danielk

Keywords: disecq removed
Milestone: 0.22unknown

comment:6 Changed 10 years ago by jansenj@…

I have been having this problem now too, specifically with Mythvideo, when the video resumes from a bookmark. This is a major pain for me because I don't use lirc to control myth at all. I only use a wireless remote that emulates a keyboard. If this doesn't get more attention, I'm going to have to figure out how to make my remote work with lirc instead. I have found that if I use ctrl-alt-right, then ctrl-alt-left, I get get focus back. Several have suggested alt-tab, but that did not work for me.

comment:7 Changed 10 years ago by robertm

Ticket locked: set

"Me too" is unhelpful.

comment:8 Changed 10 years ago by robertm

(In [23020]) Closes #7741. Refs #6815. Refs #7366. Patch by Jonatan to convert the DVD/Video bookmark popup to MythUI, preventing focus issues in some setups. Once MythVideo? uses ProgramInfo? we'll probably add the bookmark options to the playback context menu so that it more closely matches the recording screen, but this solves the immediate problem.

comment:9 Changed 9 years ago by sphery

#7355 reported another specific example--the tuner busy dialog, MythPopupBox::ShowButtonPopup?() around libs/libmythtv/tv_play.cpp +297

comment:10 Changed 9 years ago by robertm

Resolution: wontfix
Status: newclosed

The final instance mentioned here will be fixed with the setup rewrite, so just ref'ing that and closing it. Refs #8262.

Note: See TracTickets for help on using tickets.