Opened 11 years ago

Closed 10 years ago

#6826 closed defect (invalid)

Two recordings same channel, EPG

Reported by: tephra@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi All,

Even since using the "On Air Guide"/EPG I sometimes get two recordings for the same show - log:

2009-08-07 19:26:00.058 Reschedule requested for id 0. 2009-08-07 19:26:00.587 Scheduled 23 items in 0.5 = 0.00 match + 0.45 place 2009-08-07 19:26:00.597 scheduler: Scheduled items: Scheduled 23 items in 0.5 = 0.00 match + 0.45 place 2009-08-07 19:26:29.895 TVRec(5): ASK_RECORDING 5 29 0 0 2009-08-07 19:26:30.619 TVRec(6): ASK_RECORDING 6 29 0 0 2009-08-07 19:27:01.902 TVRec(5): Changing from None to Watching RecordingOnly? 2009-08-07 19:27:01.906 TVRec(5): HW Tuner: 5->5 2009-08-07 19:27:02.033 AutoExpire?: CalcParams?(): Max required Free Space: 2.0 GB w/freq: 15 min 2009-08-07 19:27:02.038 Started recording: So You Think You Can Dance "Top 12 Perform and Results": channel 1010 on cardid 5, sourceid 1 2009-08-07 19:27:02.047 scheduler: Started recording: So You Think You Can Dance "Top 12 Perform and Results": channel 1010 on cardid 5, sourceid 1 2009-08-07 19:28:37.632 Reschedule requested for id -1. 2009-08-07 19:28:38.174 Scheduled 23 items in 0.5 = 0.03 match + 0.43 place 2009-08-07 19:28:38.183 scheduler: Scheduled items: Scheduled 23 items in 0.5 = 0.03 match + 0.43 place 2009-08-07 19:30:03.198 Reschedule requested for id 0. 2009-08-07 19:30:03.666 Scheduled 23 items in 0.4 = 0.00 match + 0.38 place 2009-08-07 19:30:03.674 scheduler: Scheduled items: Scheduled 23 items in 0.4 = 0.00 match + 0.38 place 2009-08-07 19:31:05.004 UPnpMedia: BuildMediaMap? VIDEO scan starting in :/share/Movies/dvd: 2009-08-07 19:31:05.008 UPnpMedia: BuildMediaMap? Done. Found 0 objects 2009-08-07 19:31:40.535 AutoExpire?: CalcParams?(): Max required Free Space: 2.0 GB w/freq: 15 min 2009-08-07 19:33:33.637 TVRec(6): ASK_RECORDING 6 29 0 0 2009-08-07 19:33:33.726 TVRec(5): ASK_RECORDING 5 29 0 0 2009-08-07 19:34:05.128 TVRec(6): Changing from None to Watching RecordingOnly? 2009-08-07 19:34:05.132 TVRec(6): HW Tuner: 6->6 2009-08-07 19:34:05.193 AutoExpire?: CalcParams?(): Max required Free Space: 2.0 GB w/freq: 8 min 2009-08-07 19:34:05.198 Started recording: So You Think You Can Dance "Things are really starting to heat up on the floor this week. The remaining top 12 dancers are busting their way through Hip Hop": channel 1010 on cardid 6, sourceid 1 2009-08-07 19:34:05.214 scheduler: Started recording: So You Think You Can Dance "Things are really starting to heat up on the floor this week. The remaining top 12 dancers are busting their way through Hip Hop": channel 1010 on cardid 6, sourceid 1 2009-08-07 19:35:04.878 Reschedule requested for id -1. 2009-08-07 19:35:05.347 Scheduled 23 items in 0.4 = 0.02 match + 0.38 place 2009-08-07 19:35:05.356 scheduler: Scheduled items: Scheduled 23 items in 0.4 = 0.02 match + 0.38 place

Obvisouly the EPG is picking up the title change and recording the same chanid.

I am not sure if mythtv should be detecting the same chanid and ignoring the second record request?? Or maybe it assumes a different end time - so to maintain consistancy it records both?

SVN version: 21145

Cheers David

Attachments (1)

log.txt (2.6 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by anonymous

Attachment: log.txt added

comment:1 Changed 11 years ago by tephra@…

log attached since the copy/paste didn't work too well

comment:2 Changed 10 years ago by Shane Shrybman

Resolution: invalid
Status: newclosed

Hmm, I'm guessing that this may not actually be a bug.

From the scheduler's point of view those two recordings are different because the subtitles and/or descriptions are not identical. This depends on the duplicate checking policy for that recording rule. Also, the scheduler is intentionally cautious and tends to record a program when in doubt.

But, I may be wrong or misunderstanding, so if you can still reproduce this problem with a recent version please open a ticket and provide details on how the recording is being scheduled, including duplicate checking policy etc.

Note: See TracTickets for help on using tickets.