Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6980 closed defect (invalid)

VLD XvMC broken in trunk on CLE266

Reported by: rhp@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: vld xvmc cle266
Cc: Ticket locked: yes

Description

I installed mythbuntu 9.04, enabled the weekly trunk builds and upgraded everything, so now I'm running mythtv from a recent version of trunk.

VLD XvMC runs at > 80% CPU (this was 45% CPU on mythtv-0.20).

Xine still runs smoothy at 30% CPU on the same content ruling out problems with the openchrome driver.

I'm running a VIA EPIA M1000 with CLE266.

Ronald Pijnacker

Attachments (2)

mythfrontend.log (6.1 KB) - added by rhp@… 10 years ago.
mythfrontend logging
Xorg.0.log (73.4 KB) - added by rhp@… 10 years ago.
X logging

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by rhp@…

Attachment: mythfrontend.log added

mythfrontend logging

Changed 10 years ago by rhp@…

Attachment: Xorg.0.log added

X logging

comment:1 Changed 10 years ago by sphery

comment:2 in reply to:  1 Changed 10 years ago by anonymous

Replying to mdean:

This appears to be a bug in the OpenChrome? driver related to surface creation. See http://www.gossamer-threads.com/lists/mythtv/users/418072#418072 and http://www.gossamer-threads.com/lists/mythtv/users/418145#418145 .

No, the message about the not being able to create surfaces is merely a warning (albeit one that set a number of people, including myself on the wrong foot). The CPU usage is caused by how mythtv uses openchrome, since xine has no problems.

comment:3 Changed 10 years ago by danielk

Resolution: invalid
Status: newclosed

This is a driver problem, the driver needs to stop handing out surfaces when it runs low on memory.

comment:4 in reply to:  3 Changed 10 years ago by rhp

Replying to danielk:

This is a driver problem, the driver needs to stop handing out surfaces when it runs low on memory.

As you can read in my previous comment, the fact that the driver is reporting that it cannot allocate surfaces anymore is just a warning. In fact: it is actually mythtv that keeps allocating surfaces until it can't (which is the real cause of this warning).

Nevertheless: even with an updated version which allocates only 14 surfaces (and thus avoiding said warning) the CPU usage is still way to high.

Could we please start focussing on the actual problem now?

comment:5 Changed 10 years ago by robertm

Ticket locked: set

See TicketHowTo. Forward further snide remarks to prescribed location.

Note: See TracTickets for help on using tickets.