Opened 11 years ago

Closed 11 years ago

#7042 closed defect (duplicate)

Transcode Deadlock

Reported by: kincke@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Mythtranscode Version: unknown
Severity: medium Keywords: transcode, deadlock, partial frame
Cc: Ticket locked: no

Description

When clipping commercials, I get a status 232 from mythbackend. The log showed this of interest:

2009-09-13 09:44:48.535 SampleRate: Attempted to add a rate 32000 Hz, which is not in the list of allowed rates.

2009-09-13 09:44:48.638 Warning: partial frame found!
2009-09-13 09:44:48.640 Warning: partial frame found!
2009-09-13 09:44:48.641 Warning: partial frame found!
2009-09-13 09:44:48.643 Warning: partial frame found!
2009-09-13 09:44:48.644 Warning: partial frame found!
2009-09-13 09:44:48.646 Warning: partial frame found!
2009-09-13 09:44:48.647 Warning: partial frame found!
2009-09-13 09:44:48.649 Warning: partial frame found!
2009-09-13 09:44:48.650 Warning: partial frame found!
2009-09-13 09:44:48.653 Warning: partial frame found!
2009-09-13 09:44:48.655 Warning: partial frame found!
2009-09-13 09:44:48.686 #0 PTS:00:26:34.050 Delta: 0.0ms queue: 15
2009-09-13 09:44:48.687 #1 PTS:00:26:34.045 Delta: 4.65556ms queue: 4 initPTS: 00:26:34.050
2009-09-13 09:44:48.688 #2 PTS:00:26:34.042 Delta: 8.41111ms queue: 2 initPTS: 00:26:34.045
2009-09-13 09:44:54.601 Converting frame #9 from B to I
2009-09-13 09:44:54.776 Converting frame #10 from B to I
2009-09-13 09:44:54.949 Converting frame #11 from P to I
Mux rate: 12.68 Mbit/s
2009-09-13 09:44:55.358 Deadlock detected.  One buffer is full when
                the other is empty!  Aborting

2009-09-13 09:44:55.403 Transcoding 3381_20090906172700.mpg failed
2009-09-13 09:44:55.409 Deleting 3381_20090906172700.mpg.tmp
2009-09-13 09:44:55.618 JobQueue: Transcode Errored: Reaper "The Devil and Sam Oliver": Autodetect (exit status 232, job status was "Errored")

Change History (1)

comment:1 Changed 11 years ago by stuartm

Milestone: 0.22unknown
Resolution: duplicate
Status: newclosed

Duplicate of #2077

Note: See TracTickets for help on using tickets.