Opened 10 years ago

Closed 10 years ago

#7070 closed defect (fixed)

Preview doesn't work in new schedule editor

Reported by: gigem Owned by: stuartm
Priority: minor Milestone: 0.22
Component: MythTV - User Interface Library Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

The preview action doesn't seem to work with the new schedule editor. Pressing preview always shows no changes.

Also, simply "Preview" is a bit terse for that action. Perhaps "Preview Changes" or something a little more descriptive could be used.

Change History (5)

comment:1 Changed 10 years ago by stuartm

Component: MythTV - GeneralMythTV - User Interface Library
Milestone: unknown0.22
Owner: changed from Isaac Richards to stuartm
Status: newassigned
Version: unknownhead

It seems to work here, I have to actually make changes to the schedule first of course. I've never actually used this screen before, so I wouldn't know what expected behaviour is but I get a list of recordings that would be made as a result of the change.

comment:2 in reply to:  1 Changed 10 years ago by gigem

Replying to stuartm:

It seems to work here, I have to actually make changes to the schedule first of course. I've never actually used this screen before, so I wouldn't know what expected behaviour is but I get a list of recordings that would be made as a result of the change.

The whole point of the feature is to let the user see the impact of their changes without having to save the rule for real. The rule as currently edited in RAM, along with the existing record table are supposed to be saved to 'record_tmp' so the scheduler can do a test run on it. It looks like the as currently edited rule isn't getting saved, probably as a result of the new schedule editor or recent recording rule changes.

Here are two very simple test cases:

  1. Go into the guide grid and choose a program that doesn't already have a rule. Set it to record this showing only and then choose preview without saving. You should see the new program scheduled to record or marked as a conflict.
  1. Go to view scheduled and choose a program that is already scheduled to record this showing. Change the start-early setting to make it 5 minutes earlier and then choose preview without saving. You should see the program marked to record 5 minutes earlier or marked as a conflict.

comment:3 Changed 10 years ago by gigem

I need to add that some, but not all, of the problems I saw with preview changes was likely caused by the unexpected behavior reported in #7074.

comment:4 Changed 10 years ago by stuartm

(In [21894]) Make MythScreenType::Close() virtual, I neglected to check this in earlier as part of the ScheduleEditor? patch which depends on overriding Close() to save changes to RAM in the option screens. Refs #7070

comment:5 Changed 10 years ago by stuartm

Resolution: fixed
Status: assignedclosed

(In [21895]) Fix the schedule changes preview for new records. Fixes #7070. Don't assign the last_insert_id to m_recordID when using a temp table. Fixes #7075

Note: See TracTickets for help on using tickets.