Opened 10 years ago

Closed 10 years ago

#7230 closed defect (fixed)

Changeset 22171 makes scrolling a pain

Reported by: managementboy@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi, the Changeset 22171 makes the scrolling in Watch Recordings stop at every item for at least half a second if a Banner and/or Fanart is used in the recordings-ui.xml view. Regardless of if the files are in the cache or not. Previous to the patch it worked really fast.

Change History (5)

comment:1 Changed 10 years ago by stuartm

Priority: minortrivial
Severity: mediumlow
Status: newinfoneeded_new

No it doesn't, it fires off an asynchronous timer thread which should make scrolling considerably faster not cause it to pause for 0.5 seconds. What system are you using??

comment:2 Changed 10 years ago by managementboy@…

I have a Core2Duo at 2GHz and 8 Gig of Ram... should be fast enough ;-) it runs Ubuntu with the Packages at http://www.avenard.org/media/Ubuntu_Repository/Ubuntu_Repository.html the latest being trunk-22186.

All I can report is that before the ticket scrolling was a bliss, after requires a waiting period at each recording for the cursor to jump to the next. If I comment out the fanart/banners in the recordings-ui.xml its fast again.

Do you need any logs? Should I try it with other themes?

comment:3 Changed 10 years ago by managementboy@…

two more infos that might be relevant: I am using the nvidia 190.36 drivers and its 64bit version of Ubuntu Jaunty

comment:4 Changed 10 years ago by managementboy@…

I found a work around for this issue. You need to create storagegroups using mythtv-setup, for all possible image types (fanart, banners, etc). Just using the .mythtv/MythVideo/Fanart etc directories, as I had done until now, seems to have been my problem. After adding the storagegroups the scrollig works fast again, and as exected, the fanart only gets loaded when you stop at an item for more than 0,5 secs. Nice feature!

comment:5 Changed 10 years ago by cpinkham

Milestone: unknown0.22
Priority: trivialminor
Resolution: fixed
Severity: lowmedium
Status: infoneeded_newclosed
Version: unknownhead

This should be fixed by my recent [22239] commit. If the problem is still happening, please reopen and attach the log from "mythfrontend -v file,network,extra".

Note: See TracTickets for help on using tickets.