Opened 10 years ago

Closed 10 years ago

#7318 closed defect (fixed)

MythVideo hangs when changing from OpenGL to Qt

Reported by: lynchmv@… Owned by: paulh
Priority: minor Milestone: 0.23
Component: MythTV - User Interface Library Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Configure mythfrontend painter for OpenGL then quit mf. Start mf and change painter from OpenGL to Qt, then go to 'Media Library' > 'Watch Videos' and mf will display the videos I have, but hang with the 'Loading Vidoes' window/popup displayed. I have to ctrl + c the frontend to exit. This happens using Terra for the theme.

I'm not sure what needs to be logged, so let me know and I'll gladly supply them.

lynchmv@slackt43:~$ mythbackend --version

Please include all output in bug reports.

MythTV Version : 22430

MythTV Branch : trunk

Network Protocol : 50

Library API : 0.22.20091008-1

QT Version : 4.5.1

Options compiled in:

linux debug using_oss using_alsa using_backend using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live using_mheg

Attachments (3)

gdb.txt (6.7 KB) - added by lynchmv@… 10 years ago.
backtrace
7318.patch (757 bytes) - added by micahgalizia@… 10 years ago.
Fix for the bug.
7318_v2.diff (1.9 KB) - added by paulh 10 years ago.
Patch to enable/disable effects on all stacks

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by lynchmv@…

Attachment: gdb.txt added

backtrace

comment:1 Changed 10 years ago by micahgalizia@…

The problem is caused when the theme is reloaded. Only the main screen stack is told to disable and enable its effects, so the popup stack thinks it is still using the OpenGL painter.

Changed 10 years ago by micahgalizia@…

Attachment: 7318.patch added

Fix for the bug.

comment:2 Changed 10 years ago by robertm

Component: MythTV - GeneralMythTV - User Interface Library
Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:3 Changed 10 years ago by stuartm

Milestone: unknown0.23
Status: assignedaccepted

Micah thanks for debugging and the patch. Since there may be more stacks in the future I think we need a more robust fix, one which disables all effects and not just on a stack by stack basis. I work on that during the feature freeze.

Changed 10 years ago by paulh

Attachment: 7318_v2.diff added

Patch to enable/disable effects on all stacks

comment:4 Changed 10 years ago by paulh

Owner: changed from stuartm to paulh
Status: acceptedassigned

comment:5 Changed 10 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [23737]) Make sure we disable/enable the effects on all stacks not just the main stack when reloading the theme. Fixes #7318.

Note: bumps the api version so plugins need to be recompiled etc.

Note: See TracTickets for help on using tickets.