Opened 10 years ago

Closed 10 years ago

#7326 closed defect (fixed)

libmyth-0.22.dll fails to build

Reported by: markdavidoff@… Owned by: Nigel
Priority: blocker Milestone: 0.22
Component: Ports - Windows Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

myth-0.22.dll fails to build with the following error:

Creating library file: liblibmythavcodec-0.22.a
...
mtime of file (C:/mythtv/mythtv/libs/libmyth/libmyth-0.22.dll) should be greater than file (C:/mythtv/mythtv/last_build.txt)
...

Couldn't paste it all as trac thinks it is spam

Change History (3)

comment:1 Changed 10 years ago by Mark Edwards <irish@…>

I hit this last night, the actual failure is caused by changeset 22350, theres a call to usleep in libmythui, in mythmainwindow.cpp IIRC. CS 22349 builds fine for win32. Not sure how to fix it tho

comment:2 Changed 10 years ago by davidbuzz@…

having a usleep call cause the win32 build to barf is usually as result of a not including "compat.h" that defines this for win32.

comment:3 Changed 10 years ago by danielk

Resolution: fixed
Status: newclosed

(In [22470]) Fixes #7326. Fix MS Windows compilation for 0.22.

Note: See TracTickets for help on using tickets.