Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7480 closed defect (fixed)

Mythweb manual record issues

Reported by: kbass@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.22rc1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

1) Selecting a manual record and choosing a preferred input seems to be ignored. This it difficult to test recording on specific tuners.

2) Manual records do not seem to show the same 'legend' icons. For example, manual recording of an HD show did not show the HD icon. But it worked for a scheduled recording.

Attachments (1)

7480-fix-prefinput-manual-custom-schedules.diff (1.7 KB) - added by Nick Morrott <knowledgejunkie (at) gmail (dot) com> 10 years ago.
Adds timestretch/preferred input setting for manual/custom rules

Download all attachments as: .zip

Change History (5)

comment:1 in reply to:  description Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Replying to kbass@…:

1) Selecting a manual record and choosing a preferred input seems to be ignored. This it difficult to test recording on specific tuners.

Confirmed in my limited testing. record.prefinput is not being set for manual recording when a preferred input is selected.

Patch to follow.

2) Manual records do not seem to show the same 'legend' icons. For example, manual recording of an HD show did not show the HD icon. But it worked for a scheduled recording.

The data used to determine which (if any) icons are shown comes from the TV listings source, not the raw recorded stream (AFAICT). A scheduled recording will therefore typically have this data, but a manual recording will not.

comment:2 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Adding patch to permit setting preferred timestretch and preferred recording input for manual and custom recording rules.

Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Adds timestretch/preferred input setting for manual/custom rules

comment:3 Changed 10 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [23673]) Fixes #7480, this fixes the prefered input and time stretch options for manual schedules

comment:4 Changed 10 years ago by gigem

kormoc, the tsdefault field in the record table hasn't been used since the playgroup feature was added. To avoid confusion, you should probably remove any support for letting the user set it.

Note: See TracTickets for help on using tickets.