Opened 10 years ago

Closed 10 years ago

#7534 closed defect (invalid)

Memleak in Mythvideo?

Reported by: sascha.zielinski@… Owned by: Anduin Withers
Priority: minor Milestone: 0.23
Component: Plugin - MythVideo Version: head
Severity: medium Keywords: Memleak Mythtv Video mythvideo
Cc: Ticket locked: no

Description

Hi,

I use MythTV from SVN (ver. trunk [22778]). I tried loading Mythvideo but all I see is: "no videos or videos ..". I've discovered, that mythfrontend is using 7GB of 8GB RAM and 7G SWAP.

I used valgrind and attached the complete logfile (took 9 hours). I hope this log helps a bit.

Attachments (1)

memleak-error.log.tar.bz2 (26.6 KB) - added by sascha.zielinski@… 10 years ago.
valgrind -v --leak-check=full --show-reachable=yes

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by sascha.zielinski@…

Attachment: memleak-error.log.tar.bz2 added

valgrind -v --leak-check=full --show-reachable=yes

comment:1 Changed 10 years ago by sascha.zielinski@…

I checked out and compiled a fresh 0.22-fixes version from svn. The memleak problem remains. Could this be a problem of my Video tree and/or my video names?

comment:2 Changed 10 years ago by Anduin Withers

The following was sent to your email address yesterday:

The scanner is probably just looping. A more useful log would be to uncomment the VERBOSE lines in dirscan.cpp (lines 155 and 173/174). This should show where the loop is. A normal gdb backtrace could also be used to confirm it is a scanner loop (though not the cause).

Please follow-up on the mythtv-dev ml.

comment:3 Changed 10 years ago by Anduin Withers

Resolution: invalid
Status: newclosed

Submitter unresponsive.

Note: See TracTickets for help on using tickets.